Console Output

Started by upstream project "CE_RM_SPaircraft_Push" build number 744
originally caused by:
 Started by user eburn
Running as eburn
[EnvInject] - Loading node environment variables.
Building remotely on windows10x64 in workspace C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek
No credentials specified
Wiping out workspace first.
Cloning the remote Git repository
Cloning repository https://github.com/convexengineering/SPaircraft
 > C:\Program Files\Git\cmd\git init C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek # timeout=10
Fetching upstream changes from https://github.com/convexengineering/SPaircraft
 > C:\Program Files\Git\cmd\git --version # timeout=10
 > C:\Program Files\Git\cmd\git fetch --tags --progress -- https://github.com/convexengineering/SPaircraft +refs/heads/*:refs/remotes/origin/* # timeout=10
 > C:\Program Files\Git\cmd\git config remote.origin.url https://github.com/convexengineering/SPaircraft # timeout=10
 > C:\Program Files\Git\cmd\git config --add remote.origin.fetch +refs/heads/*:refs/remotes/origin/* # timeout=10
 > C:\Program Files\Git\cmd\git config remote.origin.url https://github.com/convexengineering/SPaircraft # timeout=10
Fetching upstream changes from https://github.com/convexengineering/SPaircraft
 > C:\Program Files\Git\cmd\git fetch --tags --progress -- https://github.com/convexengineering/SPaircraft +refs/heads/*:refs/remotes/origin/* # timeout=10
Checking out Revision 4570b244005341644d9371b6d5ea8775cd39d96e (refs/remotes/origin/master)
 > C:\Program Files\Git\cmd\git config core.sparsecheckout # timeout=10
 > C:\Program Files\Git\cmd\git checkout -f 4570b244005341644d9371b6d5ea8775cd39d96e # timeout=3
Commit message: "preparing for convexengineering/gpkit#1463"
 > C:\Program Files\Git\cmd\git rev-list --no-walk 4570b244005341644d9371b6d5ea8775cd39d96e # timeout=10
Run condition [Execution node ] enabling prebuild for step [Execute shell]
Run condition [Execution node ] enabling prebuild for step [Execute Windows batch command]
[Execution node] check if [windows10x64] is in [[macys, macys_VM, reynolds, reynolds-ubuntu16]]
Run condition [Execution node ] preventing perform for step [Execute shell]
[Execution node] check if [windows10x64] is in [[windows10x64, windows7x64]]
Run condition [Execution node ] enabling perform for step [Execute Windows batch command]
[mosek] $ cmd /c call C:\Users\jenkins\AppData\Local\Temp\jenkins8134989095035936447.bat

C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek>echo C:\Program Files (x86)\Common Files\Oracle\Java\javapath;C:\ProgramData\Oracle\Java\javapath;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\Anaconda2;C:\Anaconda2\Scripts;C:\Anaconda2\Library\bin;C:\Program Files\Mosek\8\tools\platform\win64x86\bin;C:\Program Files (x86)\Intel\Compiler\Fortran\9.1\EM64T\Bin;C:\WINDOWS\System32\OpenSSH\;C:\Program Files\Git\bin;C:\Program Files\TortoiseSVN\bin;C:\Program Files\Mosek\9.1\tools\platform\win64x86\bin;C:\Users\jenkins\AppData\Local\Microsoft\WindowsApps 
C:\Program Files (x86)\Common Files\Oracle\Java\javapath;C:\ProgramData\Oracle\Java\javapath;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\Anaconda2;C:\Anaconda2\Scripts;C:\Anaconda2\Library\bin;C:\Program Files\Mosek\8\tools\platform\win64x86\bin;C:\Program Files (x86)\Intel\Compiler\Fortran\9.1\EM64T\Bin;C:\WINDOWS\System32\OpenSSH\;C:\Program Files\Git\bin;C:\Program Files\TortoiseSVN\bin;C:\Program Files\Mosek\9.1\tools\platform\win64x86\bin;C:\Users\jenkins\AppData\Local\Microsoft\WindowsApps

C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek>REM turn on the anaconda console 

C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek>call activate.bat 

(base) C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek>if 0 NEQ 0 goto activate_conda 

(base) C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek>REM Create a virtualenv to install everything into 

(base) C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek>set VENV=C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek\venv2_gpkit 

(base) C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek>virtualenv --system-site-packages C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek\venv2_gpkit    || exit /b 666 
New python executable in C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek\venv2_gpkit\Scripts\python.exe
Installing setuptools, pip, wheel...done.

(base) C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek>call C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek\venv2_gpkit\Scripts\activate.bat   || exit /b 666 

(venv2_gpkit) (base) C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek>set PATH=C:\mingw-w64\x86_64-6.4.0-posix-seh-rt_v5-rev0\mingw64\bin;C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek\venv2_gpkit\Scripts;C:\Anaconda2;C:\Anaconda2\Library\mingw-w64\bin;C:\Anaconda2\Library\usr\bin;C:\Anaconda2\Library\bin;C:\Anaconda2\Scripts;C:\Anaconda2\bin;C:\Anaconda2\condabin;C:\Program Files (x86)\Common Files\Oracle\Java\javapath;C:\ProgramData\Oracle\Java\javapath;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0;C:\Anaconda2;C:\Anaconda2\Scripts;C:\Anaconda2\Library\bin;C:\Program Files\Mosek\8\tools\platform\win64x86\bin;C:\Program Files (x86)\Intel\Compiler\Fortran\9.1\EM64T\Bin;C:\WINDOWS\System32\OpenSSH;C:\Program Files\Git\bin;C:\Program Files\TortoiseSVN\bin;C:\Program Files\Mosek\9.1\tools\platform\win64x86\bin;C:\Users\jenkins\AppData\Local\Microsoft\WindowsApps 

(venv2_gpkit) (base) C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek>REM set PATH=C:\mingw-w64\x86_64-7.3.0-posix-seh-rt_v5-rev0\mingw64\bin;C:\mingw-w64\x86_64-6.4.0-posix-seh-rt_v5-rev0\mingw64\bin;C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek\venv2_gpkit\Scripts;C:\Anaconda2;C:\Anaconda2\Library\mingw-w64\bin;C:\Anaconda2\Library\usr\bin;C:\Anaconda2\Library\bin;C:\Anaconda2\Scripts;C:\Anaconda2\bin;C:\Anaconda2\condabin;C:\Program Files (x86)\Common Files\Oracle\Java\javapath;C:\ProgramData\Oracle\Java\javapath;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0;C:\Anaconda2;C:\Anaconda2\Scripts;C:\Anaconda2\Library\bin;C:\Program Files\Mosek\8\tools\platform\win64x86\bin;C:\Program Files (x86)\Intel\Compiler\Fortran\9.1\EM64T\Bin;C:\WINDOWS\System32\OpenSSH;C:\Program Files\Git\bin;C:\Program Files\TortoiseSVN\bin;C:\Program Files\Mosek\9.1\tools\platform\win64x86\bin;C:\Users\jenkins\AppData\Local\Microsoft\WindowsApps 

(venv2_gpkit) (base) C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek>gcc --version   || exit /b 666 
gcc (x86_64-posix-seh-rev0, Built by MinGW-W64 project) 6.4.0
Copyright (C) 2017 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.


(venv2_gpkit) (base) C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek>REM upgrade pip 

(venv2_gpkit) (base) C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek>python -m pip install --upgrade pip   || exit /b 666 
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
Requirement already up-to-date: pip in c:\users\jenkins\workspace\ce_rm_spaircraft_push\mosek\venv2_gpkit\lib\site-packages (20.0.2)

(venv2_gpkit) (base) C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek>REM Install coverage into the virtualenv to the coverage command blow uses the virtualenv python 

(venv2_gpkit) (base) C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek>pip install --upgrade coverage   || exit /b 666 
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
Requirement already up-to-date: coverage in c:\anaconda2\lib\site-packages (5.0.3)

(venv2_gpkit) (base) C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek>set GPKITBUILD=C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek\build_gpkit 

(venv2_gpkit) (base) C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek>if mosek == mosek (
msktestlic   || exit /b 666  
 python -c "__import__('mosek').Env()"   || exit /b 666  
 set GPKITSOLVERS=mosek, mosek_cli 
) 
Problem
  Name                   :                 
  Objective sense        : min             
  Type                   : LO (linear optimization problem)
  Constraints            : 1               
  Cones                  : 0               
  Scalar variables       : 5000            
  Matrix variables       : 0               
  Integer variables      : 0               

Optimizer started.
Mosek license manager: License path: C:\Users\jenkins\mosek\mosek.lic
Mosek license manager:  Checkout license feature 'PTS' from flexlm.
Mosek license manager:  Checkout time 0.02. r: 0 status: 0
Interior-point optimizer started.
Presolve started.
Eliminator started.
Freed constraints in eliminator : 0
Eliminator terminated.
Eliminator - tries                  : 1                 time                   : 0.00            
Lin. dep.  - tries                  : 0                 time                   : 0.00            
Lin. dep.  - number                 : 0               
Presolve terminated. Time: 0.00    
Interior-point optimizer terminated. Time: 0.00. 

Optimizer terminated. Time: 0.13    
************************************
A license was checked out correctly.
************************************

(venv2_gpkit) (base) C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek>if mosek == cvxopt (
pip install --upgrade cvxopt   || exit /b 666  
 set GPKITSOLVERS=cvxopt 
) 

(venv2_gpkit) (base) C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek>REM Install packages needed for testing 

(venv2_gpkit) (base) C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek>pip install --upgrade xmlrunner   || exit /b 666 
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
Requirement already up-to-date: xmlrunner in c:\anaconda2\lib\site-packages (1.7.7)

(venv2_gpkit) (base) C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek>pip install --upgrade pint   || exit /b 666 
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
Requirement already up-to-date: pint in c:\anaconda2\lib\site-packages (0.9)
Requirement already satisfied, skipping upgrade: funcsigs; python_version == "2.7" in c:\anaconda2\lib\site-packages (from pint) (1.0.2)

(venv2_gpkit) (base) C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek>pip install --upgrade numpy   || exit /b 666 
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
Requirement already up-to-date: numpy in c:\anaconda2\lib\site-packages (1.16.6)

(venv2_gpkit) (base) C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek>pip install --upgrade scipy   || exit /b 666 
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
Requirement already up-to-date: scipy in c:\anaconda2\lib\site-packages (1.2.3)
Requirement already satisfied, skipping upgrade: numpy>=1.8.2 in c:\anaconda2\lib\site-packages (from scipy) (1.16.6)

(venv2_gpkit) (base) C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek>pip install --upgrade ctypesgen   || exit /b 666 
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
Requirement already up-to-date: ctypesgen in c:\anaconda2\lib\site-packages (1.0.2)

(venv2_gpkit) (base) C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek>pip install --upgrade future   || exit /b 666 
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
Processing c:\users\jenkins\appdata\local\pip\cache\wheels\5f\11\0c\aad680baf5ef4fbcbab992c9f03e1130357e0c173a4fdabfff\future-0.18.2-py2-none-any.whl
Installing collected packages: future
  Attempting uninstall: future
    Found existing installation: future 0.17.1
    Not uninstalling future at c:\anaconda2\lib\site-packages, outside environment c:\users\jenkins\workspace\ce_rm_spaircraft_push\mosek\venv2_gpkit
    Can't uninstall 'future'. No files were found to uninstall.
Successfully installed future-0.18.2

(venv2_gpkit) (base) C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek>if mosek == cvxopt python -c "import cvxopt; print cvxopt.__version__" 

(venv2_gpkit) (base) C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek>python -c "import scipy; print scipy.__version__"   || exit /b 666 
1.2.3

(venv2_gpkit) (base) C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek>python -c "import numpy; print numpy.__version__"   || exit /b 666 
1.16.6

(venv2_gpkit) (base) C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek>python -c "import pint; print pint.__version__"   || exit /b 666 
0.9
C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek\venv2_gpkit\lib\site-packages\pkg_resources\py2_warn.py:19: UserWarning: ************************************************************
You are running Setuptools on Python 2, which is no longer
supported and
>>> SETUPTOOLS WILL STOP WORKING <<<
in a subsequent release. Please ensure you are installing
Setuptools using pip 9.x or later or pin to `setuptools<45`
in your environment.
If you have done those things and are still encountering
this message, please comment in
https://github.com/pypa/setuptools/issues/1458
about the steps that led to this unsupported combination.
************************************************************
  sys.version_info < (3,) and warnings.warn("*" * 60 + msg + "*" * 60)

(venv2_gpkit) (base) C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek>git --version 
git version 2.16.2.windows.1

(venv2_gpkit) (base) C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek>git clone --depth 1 https://github.com/convexengineering/gpkit.git C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek\gpkit   || exit /b 666 
Cloning into 'C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek\gpkit'...

(venv2_gpkit) (base) C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek>pip install --no-cache-dir --no-deps -e C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek\gpkit   || exit /b 666 
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
Obtaining file:///C:/Users/jenkins/workspace/CE_RM_SPaircraft_Push/mosek/gpkit
Installing collected packages: gpkit
  Running setup.py develop for gpkit
Successfully installed gpkit

(venv2_gpkit) (base) C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek>REM python -c "from gpkit.build import rebuild; rebuild()" 

(venv2_gpkit) (base) C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek>REM type C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek\gpkit\gpkit\env\settings 

(venv2_gpkit) (base) C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek>REM dir C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek\build_gpkit 

(venv2_gpkit) (base) C:\Users\jenkins\workspace\CE_RM_SPaircraft_Push\mosek>python -c "import gpkit; print(gpkit.__version__)"   || exit /b 666 
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "c:\users\jenkins\workspace\ce_rm_spaircraft_push\mosek\gpkit\gpkit\__init__.py", line 2, in <module>
    from .build import build
  File "c:\users\jenkins\workspace\ce_rm_spaircraft_push\mosek\gpkit\gpkit\build.py", line 14
    print(*args)
          ^
SyntaxError: invalid syntax
Build step 'Conditional step (single)' marked build as failure
Recording test results
ERROR: Step ‘Publish JUnit test result report’ failed: No test report files were found. Configuration error?
[WS-CLEANUP] Deleting project workspace...
[WS-CLEANUP] Deferred wipeout is used...
[WS-CLEANUP] done
Finished: FAILURE