Console Output

Started by upstream project "CE_gplibrary_Push_research_models" build number 262
originally caused by:
 Started by upstream project "CE_gpkit_Push_unit_tests" build number 794
 originally caused by:
  Started by GitHub push by bqpd
  Started by GitHub push by bqpd
Running as SYSTEM
[EnvInject] - Loading node environment variables.
Building remotely on macys_VM in workspace /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt
The recommended git tool is: NONE
using credential 3614a4cf-01de-4393-97de-73734b7dd5a2
Wiping out workspace first.
Cloning the remote Git repository
Cloning repository https://github.com/convexengineering/gplibrary
 > git init /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt # timeout=10
Fetching upstream changes from https://github.com/convexengineering/gplibrary
 > git --version # timeout=10
 > git --version # 'git version 2.24.3 (Apple Git-128)'
using GIT_SSH to set credentials 
 > git fetch --tags --force --progress -- https://github.com/convexengineering/gplibrary +refs/heads/*:refs/remotes/origin/* # timeout=10
 > git config remote.origin.url https://github.com/convexengineering/gplibrary # timeout=10
 > git config --add remote.origin.fetch +refs/heads/*:refs/remotes/origin/* # timeout=10
 > git config remote.origin.url https://github.com/convexengineering/gplibrary # timeout=10
Fetching upstream changes from https://github.com/convexengineering/gplibrary
using GIT_SSH to set credentials 
 > git fetch --tags --force --progress -- https://github.com/convexengineering/gplibrary +refs/pull/*:refs/remotes/origin/pr/* +refs/heads/master:refs/remotes/origin/master # timeout=10
Checking out Revision 3229a68974b37d818a0fe1b2bad9b448f40f7323 (origin/master)
 > git config core.sparsecheckout # timeout=10
 > git checkout -f 3229a68974b37d818a0fe1b2bad9b448f40f7323 # timeout=3
Commit message: "remove adnumber"
 > git rev-list --no-walk 3229a68974b37d818a0fe1b2bad9b448f40f7323 # timeout=10
The recommended git tool is: NONE
using credential 3614a4cf-01de-4393-97de-73734b7dd5a2
 > git rev-parse 3229a68974b37d818a0fe1b2bad9b448f40f7323^{commit} # timeout=10
The recommended git tool is: NONE
using credential 3614a4cf-01de-4393-97de-73734b7dd5a2
[GitCheckoutListener] Recording commits of 'git https://github.com/convexengineering/gplibrary'
[GitCheckoutListener] Found previous build 'CE_gplibrary_Push_research_models/buildnode=macys_VM,optimizer=cvxopt #261' that contains recorded Git commits
[GitCheckoutListener] -> Starting recording of new commits since '3229a68'
[GitCheckoutListener] -> Using head commit '3229a68' as starting point
[GitCheckoutListener] -> Git commit decorator successfully obtained 'hudson.plugins.git.browser.GithubWeb@c6abc2b' to render commit links
[GitCheckoutListener] -> No new commits found
Run condition [Execution node ] enabling prebuild for step [Execute shell]
Run condition [Execution node ] enabling prebuild for step [Execute Windows batch command]
[Execution node] check if [macys_VM] is in [[macys, macys_VM, reynolds, reynolds-ubuntu16]]
Run condition [Execution node ] enabling perform for step [Execute shell]
[cvxopt] $ /bin/bash -xe /var/folders/qk/9zkf0syn149fvhw9mh7hgd5w0000gp/T/jenkins6258085878199499024.sh
+ git clone ssh://acdl.mit.edu/home/svnroot/JenkinsGPkit
Cloning into 'JenkinsGPkit'...
+ source /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/JenkinsGPkit/gplibrary_models.sh
++ source /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/JenkinsGPkit/all_machines.sh
+++ export PYTHONHASHSEED=0
+++ PYTHONHASHSEED=0
+++ echo 'Python hash seed set to: 0'
Python hash seed set to: 0
+++ [[ macys_VM == *macys* ]]
+++ export PATH=/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin/
+++ PATH=/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin/
+++ virtualenv --python=python3 /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins
/usr/local/lib/python3.9/site-packages/setuptools/command/install.py:34: SetuptoolsDeprecationWarning: setup.py install is deprecated. Use build and pip and other standards-based tools.
  warnings.warn(
created virtual environment CPython3.9.10.final.0-64 in 1221ms
  creator CPython3Posix(dest=/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins, clear=False, no_vcs_ignore=False, global=False)
  seeder FromAppData(download=False, pip=bundle, setuptools=bundle, wheel=bundle, via=copy, app_data_dir=/Users/jenkins/Library/Application Support/virtualenv)
    added seed packages: pip==21.1.3, setuptools==60.9.3, wheel==0.37.1
  activators BashActivator,CShellActivator,FishActivator,PowerShellActivator,PythonActivator,XonshActivator
+++ source /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/bin/activate
++++ '[' /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/bin/activate = /var/folders/qk/9zkf0syn149fvhw9mh7hgd5w0000gp/T/jenkins6258085878199499024.sh ']'
++++ deactivate nondestructive
++++ unset -f pydoc
++++ '[' -z '' ']'
++++ '[' -z '' ']'
++++ hash -r
++++ '[' -z '' ']'
++++ unset VIRTUAL_ENV
++++ '[' '!' nondestructive = nondestructive ']'
++++ VIRTUAL_ENV=/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins
++++ '[' darwin19 = cygwin ']'
++++ '[' darwin19 = msys ']'
++++ export VIRTUAL_ENV
++++ _OLD_VIRTUAL_PATH=/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin/
++++ PATH=/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin/
++++ export PATH
++++ '[' -z '' ']'
++++ '[' -z '' ']'
++++ _OLD_VIRTUAL_PS1=
++++ '[' x '!=' x ']'
+++++ basename /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins
++++ PS1='(venv_jenkins) '
++++ export PS1
++++ alias pydoc
++++ true
++++ hash -r
+++ ls /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt
EXTERNALTESTS
EXTERNALTESTSreadme.md
JenkinsGPkit
LICENSE
README.md
TESTCONFIG
TESTS
gpkitmodels
researchmodeltests.sh
runtests.sh
setup.py
venv_jenkins
++++ which pip
+++ export PIP=/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/bin/pip
+++ PIP=/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/bin/pip
+++ pip_install pip
+++ python /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/bin/pip install --upgrade pip
Requirement already satisfied: pip in ./venv_jenkins/lib/python3.9/site-packages (21.1.3)
Collecting pip
  Using cached pip-22.0.4-py3-none-any.whl (2.1 MB)
Installing collected packages: pip
  Attempting uninstall: pip
    Found existing installation: pip 21.1.3
    Uninstalling pip-21.1.3:
      Successfully uninstalled pip-21.1.3
Successfully installed pip-22.0.4

real	0m3.132s
user	0m1.875s
sys	0m0.688s
++ source /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/JenkinsGPkit/mosek_installs.sh
+++ [[ cvxopt == mosek ]]
++ source /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/JenkinsGPkit/cvxopt_installs.sh
+++ [[ cvxopt == cvxopt ]]
+++ pip_install cvxopt
+++ python /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/bin/pip install --upgrade cvxopt
Collecting cvxopt
  Using cached cvxopt-1.3.0-cp39-cp39-macosx_10_9_x86_64.whl (3.1 MB)
Installing collected packages: cvxopt
Successfully installed cvxopt-1.3.0

real	0m0.784s
user	0m0.613s
sys	0m0.114s
+++ python -c 'import cvxopt'
+++ export GPKITSOLVERS=cvxopt
+++ GPKITSOLVERS=cvxopt
+++ COVERAGE_OMIT='gpkit/solvers/mosek*'
++ source /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/JenkinsGPkit/pip_installs_base.sh
+++ pip_install adce
+++ python /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/bin/pip install --upgrade adce
Collecting adce
  Using cached adce-1.3.3.2-py3-none-any.whl
Installing collected packages: adce
Successfully installed adce-1.3.3.2

real	0m0.734s
user	0m0.458s
sys	0m0.080s
+++ pip_install unittest-xml-reporting
+++ python /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/bin/pip install --upgrade unittest-xml-reporting
Collecting unittest-xml-reporting
  Using cached unittest_xml_reporting-3.2.0-py2.py3-none-any.whl (20 kB)
Collecting lxml
  Using cached lxml-4.8.0-cp39-cp39-macosx_10_15_x86_64.whl (4.6 MB)
Installing collected packages: lxml, unittest-xml-reporting
Successfully installed lxml-4.8.0 unittest-xml-reporting-3.2.0

real	0m1.178s
user	0m0.903s
sys	0m0.149s
+++ pip_install pandas
+++ python /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/bin/pip install --upgrade pandas
Collecting pandas
  Using cached pandas-1.4.1-cp39-cp39-macosx_10_9_x86_64.whl (11.5 MB)
Collecting python-dateutil>=2.8.1
  Using cached python_dateutil-2.8.2-py2.py3-none-any.whl (247 kB)
Collecting pytz>=2020.1
  Using cached pytz-2022.1-py2.py3-none-any.whl (503 kB)
Collecting numpy>=1.18.5
  Using cached numpy-1.22.3-cp39-cp39-macosx_10_14_x86_64.whl (17.6 MB)
Collecting six>=1.5
  Using cached six-1.16.0-py2.py3-none-any.whl (11 kB)
Installing collected packages: pytz, six, numpy, python-dateutil, pandas
Successfully installed numpy-1.22.3 pandas-1.4.1 python-dateutil-2.8.2 pytz-2022.1 six-1.16.0

real	0m8.643s
user	0m6.040s
sys	0m1.551s
+++ pip_install matplotlib
+++ python /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/bin/pip install --upgrade matplotlib
Collecting matplotlib
  Using cached matplotlib-3.5.1-cp39-cp39-macosx_10_9_x86_64.whl (7.3 MB)
Requirement already satisfied: python-dateutil>=2.7 in ./venv_jenkins/lib/python3.9/site-packages (from matplotlib) (2.8.2)
Collecting packaging>=20.0
  Using cached packaging-21.3-py3-none-any.whl (40 kB)
Collecting kiwisolver>=1.0.1
  Using cached kiwisolver-1.4.2-cp39-cp39-macosx_10_9_x86_64.whl (65 kB)
Collecting cycler>=0.10
  Using cached cycler-0.11.0-py3-none-any.whl (6.4 kB)
Collecting pillow>=6.2.0
  Using cached Pillow-9.0.1-cp39-cp39-macosx_10_10_x86_64.whl (3.0 MB)
Requirement already satisfied: numpy>=1.17 in ./venv_jenkins/lib/python3.9/site-packages (from matplotlib) (1.22.3)
Collecting pyparsing>=2.2.1
  Using cached pyparsing-3.0.7-py3-none-any.whl (98 kB)
Collecting fonttools>=4.22.0
  Using cached fonttools-4.31.2-py3-none-any.whl (899 kB)
Requirement already satisfied: six>=1.5 in ./venv_jenkins/lib/python3.9/site-packages (from python-dateutil>=2.7->matplotlib) (1.16.0)
Installing collected packages: pyparsing, pillow, kiwisolver, fonttools, cycler, packaging, matplotlib
Successfully installed cycler-0.11.0 fonttools-4.31.2 kiwisolver-1.4.2 matplotlib-3.5.1 packaging-21.3 pillow-9.0.1 pyparsing-3.0.7

real	0m4.439s
user	0m3.143s
sys	0m0.626s
+++ pip_install coverage
+++ python /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/bin/pip install --upgrade coverage
Collecting coverage
  Using cached coverage-6.3.2-cp39-cp39-macosx_10_9_x86_64.whl (183 kB)
Installing collected packages: coverage
Successfully installed coverage-6.3.2

real	0m1.142s
user	0m0.981s
sys	0m0.113s
+++ pip_install ipywidgets
+++ python /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/bin/pip install --upgrade ipywidgets
Collecting ipywidgets
  Using cached ipywidgets-7.7.0-py2.py3-none-any.whl (123 kB)
Collecting ipython>=4.0.0
  Using cached ipython-8.2.0-py3-none-any.whl (750 kB)
Collecting ipykernel>=4.5.1
  Using cached ipykernel-6.10.0-py3-none-any.whl (130 kB)
Collecting ipython-genutils~=0.2.0
  Using cached ipython_genutils-0.2.0-py2.py3-none-any.whl (26 kB)
Collecting widgetsnbextension~=3.6.0
  Using cached widgetsnbextension-3.6.0-py2.py3-none-any.whl (1.6 MB)
Collecting nbformat>=4.2.0
  Using cached nbformat-5.2.0-py3-none-any.whl (74 kB)
Collecting traitlets>=4.3.1
  Using cached traitlets-5.1.1-py3-none-any.whl (102 kB)
Collecting jupyterlab-widgets>=1.0.0
  Using cached jupyterlab_widgets-1.1.0-py3-none-any.whl (245 kB)
Collecting appnope
  Using cached appnope-0.1.2-py2.py3-none-any.whl (4.3 kB)
Collecting psutil
  Using cached psutil-5.9.0-cp39-cp39-macosx_10_9_x86_64.whl (238 kB)
Collecting nest-asyncio
  Using cached nest_asyncio-1.5.4-py3-none-any.whl (5.1 kB)
Collecting jupyter-client<8.0
  Using cached jupyter_client-7.2.0-py3-none-any.whl (130 kB)
Collecting tornado<7.0,>=5.0
  Using cached tornado-6.1-cp39-cp39-macosx_10_9_x86_64.whl (416 kB)
Collecting debugpy<2.0,>=1.0.0
  Using cached debugpy-1.6.0-cp39-cp39-macosx_10_15_x86_64.whl (1.7 MB)
Collecting matplotlib-inline<0.2.0,>=0.1.0
  Using cached matplotlib_inline-0.1.3-py3-none-any.whl (8.2 kB)
Collecting pexpect>4.3
  Using cached pexpect-4.8.0-py2.py3-none-any.whl (59 kB)
Collecting stack-data
  Using cached stack_data-0.2.0-py3-none-any.whl (21 kB)
Collecting pickleshare
  Using cached pickleshare-0.7.5-py2.py3-none-any.whl (6.9 kB)
Collecting backcall
  Using cached backcall-0.2.0-py2.py3-none-any.whl (11 kB)
Collecting prompt-toolkit!=3.0.0,!=3.0.1,<3.1.0,>=2.0.0
  Using cached prompt_toolkit-3.0.28-py3-none-any.whl (380 kB)
Collecting decorator
  Using cached decorator-5.1.1-py3-none-any.whl (9.1 kB)
Collecting pygments>=2.4.0
  Using cached Pygments-2.11.2-py3-none-any.whl (1.1 MB)
Collecting jedi>=0.16
  Using cached jedi-0.18.1-py2.py3-none-any.whl (1.6 MB)
Requirement already satisfied: setuptools>=18.5 in ./venv_jenkins/lib/python3.9/site-packages (from ipython>=4.0.0->ipywidgets) (60.9.3)
Collecting jupyter-core
  Using cached jupyter_core-4.9.2-py3-none-any.whl (86 kB)
Collecting jsonschema!=2.5.0,>=2.4
  Using cached jsonschema-4.4.0-py3-none-any.whl (72 kB)
Collecting notebook>=4.4.1
  Using cached notebook-6.4.10-py3-none-any.whl (9.9 MB)
Collecting parso<0.9.0,>=0.8.0
  Using cached parso-0.8.3-py2.py3-none-any.whl (100 kB)
Collecting attrs>=17.4.0
  Using cached attrs-21.4.0-py2.py3-none-any.whl (60 kB)
Collecting pyrsistent!=0.17.0,!=0.17.1,!=0.17.2,>=0.14.0
  Using cached pyrsistent-0.18.1-cp39-cp39-macosx_10_9_universal2.whl (81 kB)
Collecting entrypoints
  Using cached entrypoints-0.4-py3-none-any.whl (5.3 kB)
Requirement already satisfied: python-dateutil>=2.1 in ./venv_jenkins/lib/python3.9/site-packages (from jupyter-client<8.0->ipykernel>=4.5.1->ipywidgets) (2.8.2)
Collecting pyzmq>=17
  Using cached pyzmq-22.3.0-cp39-cp39-macosx_10_15_universal2.whl (2.0 MB)
Collecting jinja2
  Using cached Jinja2-3.1.1-py3-none-any.whl (132 kB)
Collecting terminado>=0.8.3
  Using cached terminado-0.13.3-py3-none-any.whl (14 kB)
Collecting prometheus-client
  Using cached prometheus_client-0.13.1-py3-none-any.whl (57 kB)
Collecting nbconvert>=5
  Using cached nbconvert-6.4.5-py3-none-any.whl (561 kB)
Collecting argon2-cffi
  Using cached argon2_cffi-21.3.0-py3-none-any.whl (14 kB)
Collecting Send2Trash>=1.8.0
  Using cached Send2Trash-1.8.0-py3-none-any.whl (18 kB)
Collecting ptyprocess>=0.5
  Using cached ptyprocess-0.7.0-py2.py3-none-any.whl (13 kB)
Collecting wcwidth
  Using cached wcwidth-0.2.5-py2.py3-none-any.whl (30 kB)
Collecting asttokens
  Using cached asttokens-2.0.5-py2.py3-none-any.whl (20 kB)
Collecting pure-eval
  Using cached pure_eval-0.2.2-py3-none-any.whl (11 kB)
Collecting executing
  Using cached executing-0.8.3-py2.py3-none-any.whl (16 kB)
Collecting pandocfilters>=1.4.1
  Using cached pandocfilters-1.5.0-py2.py3-none-any.whl (8.7 kB)
Collecting defusedxml
  Using cached defusedxml-0.7.1-py2.py3-none-any.whl (25 kB)
Collecting nbclient<0.6.0,>=0.5.0
  Using cached nbclient-0.5.13-py3-none-any.whl (70 kB)
Collecting beautifulsoup4
  Using cached beautifulsoup4-4.10.0-py3-none-any.whl (97 kB)
Collecting testpath
  Using cached testpath-0.6.0-py3-none-any.whl (83 kB)
Collecting bleach
  Using cached bleach-4.1.0-py2.py3-none-any.whl (157 kB)
Collecting jupyterlab-pygments
  Using cached jupyterlab_pygments-0.1.2-py2.py3-none-any.whl (4.6 kB)
Collecting MarkupSafe>=2.0
  Using cached MarkupSafe-2.1.1-cp39-cp39-macosx_10_9_x86_64.whl (13 kB)
Collecting mistune<2,>=0.8.1
  Using cached mistune-0.8.4-py2.py3-none-any.whl (16 kB)
Requirement already satisfied: six>=1.5 in ./venv_jenkins/lib/python3.9/site-packages (from python-dateutil>=2.1->jupyter-client<8.0->ipykernel>=4.5.1->ipywidgets) (1.16.0)
Collecting argon2-cffi-bindings
  Using cached argon2_cffi_bindings-21.2.0-cp38-abi3-macosx_10_9_universal2.whl (53 kB)
Collecting cffi>=1.0.1
  Using cached cffi-1.15.0-cp39-cp39-macosx_10_9_x86_64.whl (178 kB)
Collecting soupsieve>1.2
  Using cached soupsieve-2.3.1-py3-none-any.whl (37 kB)
Requirement already satisfied: packaging in ./venv_jenkins/lib/python3.9/site-packages (from bleach->nbconvert>=5->notebook>=4.4.1->widgetsnbextension~=3.6.0->ipywidgets) (21.3)
Collecting webencodings
  Using cached webencodings-0.5.1-py2.py3-none-any.whl (11 kB)
Collecting pycparser
  Using cached pycparser-2.21-py2.py3-none-any.whl (118 kB)
Requirement already satisfied: pyparsing!=3.0.5,>=2.0.2 in ./venv_jenkins/lib/python3.9/site-packages (from packaging->bleach->nbconvert>=5->notebook>=4.4.1->widgetsnbextension~=3.6.0->ipywidgets) (3.0.7)
Installing collected packages: webencodings, wcwidth, Send2Trash, pure-eval, ptyprocess, pickleshare, mistune, ipython-genutils, executing, backcall, appnope, traitlets, tornado, testpath, soupsieve, pyzmq, pyrsistent, pygments, pycparser, psutil, prompt-toolkit, prometheus-client, pexpect, parso, pandocfilters, nest-asyncio, MarkupSafe, jupyterlab-widgets, entrypoints, defusedxml, decorator, debugpy, attrs, asttokens, terminado, stack-data, matplotlib-inline, jupyterlab-pygments, jupyter-core, jsonschema, jinja2, jedi, cffi, bleach, beautifulsoup4, nbformat, jupyter-client, ipython, argon2-cffi-bindings, nbclient, ipykernel, argon2-cffi, nbconvert, notebook, widgetsnbextension, ipywidgets
Successfully installed MarkupSafe-2.1.1 Send2Trash-1.8.0 appnope-0.1.2 argon2-cffi-21.3.0 argon2-cffi-bindings-21.2.0 asttokens-2.0.5 attrs-21.4.0 backcall-0.2.0 beautifulsoup4-4.10.0 bleach-4.1.0 cffi-1.15.0 debugpy-1.6.0 decorator-5.1.1 defusedxml-0.7.1 entrypoints-0.4 executing-0.8.3 ipykernel-6.10.0 ipython-8.2.0 ipython-genutils-0.2.0 ipywidgets-7.7.0 jedi-0.18.1 jinja2-3.1.1 jsonschema-4.4.0 jupyter-client-7.2.0 jupyter-core-4.9.2 jupyterlab-pygments-0.1.2 jupyterlab-widgets-1.1.0 matplotlib-inline-0.1.3 mistune-0.8.4 nbclient-0.5.13 nbconvert-6.4.5 nbformat-5.2.0 nest-asyncio-1.5.4 notebook-6.4.10 pandocfilters-1.5.0 parso-0.8.3 pexpect-4.8.0 pickleshare-0.7.5 prometheus-client-0.13.1 prompt-toolkit-3.0.28 psutil-5.9.0 ptyprocess-0.7.0 pure-eval-0.2.2 pycparser-2.21 pygments-2.11.2 pyrsistent-0.18.1 pyzmq-22.3.0 soupsieve-2.3.1 stack-data-0.2.0 terminado-0.13.3 testpath-0.6.0 tornado-6.1 traitlets-5.1.1 wcwidth-0.2.5 webencodings-0.5.1 widgetsnbextension-3.6.0

real	0m14.141s
user	0m8.353s
sys	0m2.374s
+++ pip_install ipysankeywidget
+++ python /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/bin/pip install --upgrade ipysankeywidget
Collecting ipysankeywidget
  Using cached ipysankeywidget-0.4.1-py2.py3-none-any.whl (1.2 MB)
Requirement already satisfied: ipywidgets>=7.0.0 in ./venv_jenkins/lib/python3.9/site-packages (from ipysankeywidget) (7.7.0)
Requirement already satisfied: traitlets>=4.3.1 in ./venv_jenkins/lib/python3.9/site-packages (from ipywidgets>=7.0.0->ipysankeywidget) (5.1.1)
Requirement already satisfied: nbformat>=4.2.0 in ./venv_jenkins/lib/python3.9/site-packages (from ipywidgets>=7.0.0->ipysankeywidget) (5.2.0)
Requirement already satisfied: ipykernel>=4.5.1 in ./venv_jenkins/lib/python3.9/site-packages (from ipywidgets>=7.0.0->ipysankeywidget) (6.10.0)
Requirement already satisfied: ipython>=4.0.0 in ./venv_jenkins/lib/python3.9/site-packages (from ipywidgets>=7.0.0->ipysankeywidget) (8.2.0)
Requirement already satisfied: widgetsnbextension~=3.6.0 in ./venv_jenkins/lib/python3.9/site-packages (from ipywidgets>=7.0.0->ipysankeywidget) (3.6.0)
Requirement already satisfied: ipython-genutils~=0.2.0 in ./venv_jenkins/lib/python3.9/site-packages (from ipywidgets>=7.0.0->ipysankeywidget) (0.2.0)
Requirement already satisfied: jupyterlab-widgets>=1.0.0 in ./venv_jenkins/lib/python3.9/site-packages (from ipywidgets>=7.0.0->ipysankeywidget) (1.1.0)
Requirement already satisfied: nest-asyncio in ./venv_jenkins/lib/python3.9/site-packages (from ipykernel>=4.5.1->ipywidgets>=7.0.0->ipysankeywidget) (1.5.4)
Requirement already satisfied: appnope in ./venv_jenkins/lib/python3.9/site-packages (from ipykernel>=4.5.1->ipywidgets>=7.0.0->ipysankeywidget) (0.1.2)
Requirement already satisfied: psutil in ./venv_jenkins/lib/python3.9/site-packages (from ipykernel>=4.5.1->ipywidgets>=7.0.0->ipysankeywidget) (5.9.0)
Requirement already satisfied: jupyter-client<8.0 in ./venv_jenkins/lib/python3.9/site-packages (from ipykernel>=4.5.1->ipywidgets>=7.0.0->ipysankeywidget) (7.2.0)
Requirement already satisfied: matplotlib-inline<0.2.0,>=0.1.0 in ./venv_jenkins/lib/python3.9/site-packages (from ipykernel>=4.5.1->ipywidgets>=7.0.0->ipysankeywidget) (0.1.3)
Requirement already satisfied: tornado<7.0,>=5.0 in ./venv_jenkins/lib/python3.9/site-packages (from ipykernel>=4.5.1->ipywidgets>=7.0.0->ipysankeywidget) (6.1)
Requirement already satisfied: debugpy<2.0,>=1.0.0 in ./venv_jenkins/lib/python3.9/site-packages (from ipykernel>=4.5.1->ipywidgets>=7.0.0->ipysankeywidget) (1.6.0)
Requirement already satisfied: backcall in ./venv_jenkins/lib/python3.9/site-packages (from ipython>=4.0.0->ipywidgets>=7.0.0->ipysankeywidget) (0.2.0)
Requirement already satisfied: stack-data in ./venv_jenkins/lib/python3.9/site-packages (from ipython>=4.0.0->ipywidgets>=7.0.0->ipysankeywidget) (0.2.0)
Requirement already satisfied: jedi>=0.16 in ./venv_jenkins/lib/python3.9/site-packages (from ipython>=4.0.0->ipywidgets>=7.0.0->ipysankeywidget) (0.18.1)
Requirement already satisfied: setuptools>=18.5 in ./venv_jenkins/lib/python3.9/site-packages (from ipython>=4.0.0->ipywidgets>=7.0.0->ipysankeywidget) (60.9.3)
Requirement already satisfied: pickleshare in ./venv_jenkins/lib/python3.9/site-packages (from ipython>=4.0.0->ipywidgets>=7.0.0->ipysankeywidget) (0.7.5)
Requirement already satisfied: prompt-toolkit!=3.0.0,!=3.0.1,<3.1.0,>=2.0.0 in ./venv_jenkins/lib/python3.9/site-packages (from ipython>=4.0.0->ipywidgets>=7.0.0->ipysankeywidget) (3.0.28)
Requirement already satisfied: decorator in ./venv_jenkins/lib/python3.9/site-packages (from ipython>=4.0.0->ipywidgets>=7.0.0->ipysankeywidget) (5.1.1)
Requirement already satisfied: pygments>=2.4.0 in ./venv_jenkins/lib/python3.9/site-packages (from ipython>=4.0.0->ipywidgets>=7.0.0->ipysankeywidget) (2.11.2)
Requirement already satisfied: pexpect>4.3 in ./venv_jenkins/lib/python3.9/site-packages (from ipython>=4.0.0->ipywidgets>=7.0.0->ipysankeywidget) (4.8.0)
Requirement already satisfied: jupyter-core in ./venv_jenkins/lib/python3.9/site-packages (from nbformat>=4.2.0->ipywidgets>=7.0.0->ipysankeywidget) (4.9.2)
Requirement already satisfied: jsonschema!=2.5.0,>=2.4 in ./venv_jenkins/lib/python3.9/site-packages (from nbformat>=4.2.0->ipywidgets>=7.0.0->ipysankeywidget) (4.4.0)
Requirement already satisfied: notebook>=4.4.1 in ./venv_jenkins/lib/python3.9/site-packages (from widgetsnbextension~=3.6.0->ipywidgets>=7.0.0->ipysankeywidget) (6.4.10)
Requirement already satisfied: parso<0.9.0,>=0.8.0 in ./venv_jenkins/lib/python3.9/site-packages (from jedi>=0.16->ipython>=4.0.0->ipywidgets>=7.0.0->ipysankeywidget) (0.8.3)
Requirement already satisfied: pyrsistent!=0.17.0,!=0.17.1,!=0.17.2,>=0.14.0 in ./venv_jenkins/lib/python3.9/site-packages (from jsonschema!=2.5.0,>=2.4->nbformat>=4.2.0->ipywidgets>=7.0.0->ipysankeywidget) (0.18.1)
Requirement already satisfied: attrs>=17.4.0 in ./venv_jenkins/lib/python3.9/site-packages (from jsonschema!=2.5.0,>=2.4->nbformat>=4.2.0->ipywidgets>=7.0.0->ipysankeywidget) (21.4.0)
Requirement already satisfied: python-dateutil>=2.1 in ./venv_jenkins/lib/python3.9/site-packages (from jupyter-client<8.0->ipykernel>=4.5.1->ipywidgets>=7.0.0->ipysankeywidget) (2.8.2)
Requirement already satisfied: entrypoints in ./venv_jenkins/lib/python3.9/site-packages (from jupyter-client<8.0->ipykernel>=4.5.1->ipywidgets>=7.0.0->ipysankeywidget) (0.4)
Requirement already satisfied: pyzmq>=17 in ./venv_jenkins/lib/python3.9/site-packages (from jupyter-client<8.0->ipykernel>=4.5.1->ipywidgets>=7.0.0->ipysankeywidget) (22.3.0)
Requirement already satisfied: Send2Trash>=1.8.0 in ./venv_jenkins/lib/python3.9/site-packages (from notebook>=4.4.1->widgetsnbextension~=3.6.0->ipywidgets>=7.0.0->ipysankeywidget) (1.8.0)
Requirement already satisfied: terminado>=0.8.3 in ./venv_jenkins/lib/python3.9/site-packages (from notebook>=4.4.1->widgetsnbextension~=3.6.0->ipywidgets>=7.0.0->ipysankeywidget) (0.13.3)
Requirement already satisfied: prometheus-client in ./venv_jenkins/lib/python3.9/site-packages (from notebook>=4.4.1->widgetsnbextension~=3.6.0->ipywidgets>=7.0.0->ipysankeywidget) (0.13.1)
Requirement already satisfied: jinja2 in ./venv_jenkins/lib/python3.9/site-packages (from notebook>=4.4.1->widgetsnbextension~=3.6.0->ipywidgets>=7.0.0->ipysankeywidget) (3.1.1)
Requirement already satisfied: nbconvert>=5 in ./venv_jenkins/lib/python3.9/site-packages (from notebook>=4.4.1->widgetsnbextension~=3.6.0->ipywidgets>=7.0.0->ipysankeywidget) (6.4.5)
Requirement already satisfied: argon2-cffi in ./venv_jenkins/lib/python3.9/site-packages (from notebook>=4.4.1->widgetsnbextension~=3.6.0->ipywidgets>=7.0.0->ipysankeywidget) (21.3.0)
Requirement already satisfied: ptyprocess>=0.5 in ./venv_jenkins/lib/python3.9/site-packages (from pexpect>4.3->ipython>=4.0.0->ipywidgets>=7.0.0->ipysankeywidget) (0.7.0)
Requirement already satisfied: wcwidth in ./venv_jenkins/lib/python3.9/site-packages (from prompt-toolkit!=3.0.0,!=3.0.1,<3.1.0,>=2.0.0->ipython>=4.0.0->ipywidgets>=7.0.0->ipysankeywidget) (0.2.5)
Requirement already satisfied: executing in ./venv_jenkins/lib/python3.9/site-packages (from stack-data->ipython>=4.0.0->ipywidgets>=7.0.0->ipysankeywidget) (0.8.3)
Requirement already satisfied: asttokens in ./venv_jenkins/lib/python3.9/site-packages (from stack-data->ipython>=4.0.0->ipywidgets>=7.0.0->ipysankeywidget) (2.0.5)
Requirement already satisfied: pure-eval in ./venv_jenkins/lib/python3.9/site-packages (from stack-data->ipython>=4.0.0->ipywidgets>=7.0.0->ipysankeywidget) (0.2.2)
Requirement already satisfied: pandocfilters>=1.4.1 in ./venv_jenkins/lib/python3.9/site-packages (from nbconvert>=5->notebook>=4.4.1->widgetsnbextension~=3.6.0->ipywidgets>=7.0.0->ipysankeywidget) (1.5.0)
Requirement already satisfied: jupyterlab-pygments in ./venv_jenkins/lib/python3.9/site-packages (from nbconvert>=5->notebook>=4.4.1->widgetsnbextension~=3.6.0->ipywidgets>=7.0.0->ipysankeywidget) (0.1.2)
Requirement already satisfied: beautifulsoup4 in ./venv_jenkins/lib/python3.9/site-packages (from nbconvert>=5->notebook>=4.4.1->widgetsnbextension~=3.6.0->ipywidgets>=7.0.0->ipysankeywidget) (4.10.0)
Requirement already satisfied: bleach in ./venv_jenkins/lib/python3.9/site-packages (from nbconvert>=5->notebook>=4.4.1->widgetsnbextension~=3.6.0->ipywidgets>=7.0.0->ipysankeywidget) (4.1.0)
Requirement already satisfied: defusedxml in ./venv_jenkins/lib/python3.9/site-packages (from nbconvert>=5->notebook>=4.4.1->widgetsnbextension~=3.6.0->ipywidgets>=7.0.0->ipysankeywidget) (0.7.1)
Requirement already satisfied: MarkupSafe>=2.0 in ./venv_jenkins/lib/python3.9/site-packages (from nbconvert>=5->notebook>=4.4.1->widgetsnbextension~=3.6.0->ipywidgets>=7.0.0->ipysankeywidget) (2.1.1)
Requirement already satisfied: testpath in ./venv_jenkins/lib/python3.9/site-packages (from nbconvert>=5->notebook>=4.4.1->widgetsnbextension~=3.6.0->ipywidgets>=7.0.0->ipysankeywidget) (0.6.0)
Requirement already satisfied: mistune<2,>=0.8.1 in ./venv_jenkins/lib/python3.9/site-packages (from nbconvert>=5->notebook>=4.4.1->widgetsnbextension~=3.6.0->ipywidgets>=7.0.0->ipysankeywidget) (0.8.4)
Requirement already satisfied: nbclient<0.6.0,>=0.5.0 in ./venv_jenkins/lib/python3.9/site-packages (from nbconvert>=5->notebook>=4.4.1->widgetsnbextension~=3.6.0->ipywidgets>=7.0.0->ipysankeywidget) (0.5.13)
Requirement already satisfied: six>=1.5 in ./venv_jenkins/lib/python3.9/site-packages (from python-dateutil>=2.1->jupyter-client<8.0->ipykernel>=4.5.1->ipywidgets>=7.0.0->ipysankeywidget) (1.16.0)
Requirement already satisfied: argon2-cffi-bindings in ./venv_jenkins/lib/python3.9/site-packages (from argon2-cffi->notebook>=4.4.1->widgetsnbextension~=3.6.0->ipywidgets>=7.0.0->ipysankeywidget) (21.2.0)
Requirement already satisfied: cffi>=1.0.1 in ./venv_jenkins/lib/python3.9/site-packages (from argon2-cffi-bindings->argon2-cffi->notebook>=4.4.1->widgetsnbextension~=3.6.0->ipywidgets>=7.0.0->ipysankeywidget) (1.15.0)
Requirement already satisfied: soupsieve>1.2 in ./venv_jenkins/lib/python3.9/site-packages (from beautifulsoup4->nbconvert>=5->notebook>=4.4.1->widgetsnbextension~=3.6.0->ipywidgets>=7.0.0->ipysankeywidget) (2.3.1)
Requirement already satisfied: webencodings in ./venv_jenkins/lib/python3.9/site-packages (from bleach->nbconvert>=5->notebook>=4.4.1->widgetsnbextension~=3.6.0->ipywidgets>=7.0.0->ipysankeywidget) (0.5.1)
Requirement already satisfied: packaging in ./venv_jenkins/lib/python3.9/site-packages (from bleach->nbconvert>=5->notebook>=4.4.1->widgetsnbextension~=3.6.0->ipywidgets>=7.0.0->ipysankeywidget) (21.3)
Requirement already satisfied: pycparser in ./venv_jenkins/lib/python3.9/site-packages (from cffi>=1.0.1->argon2-cffi-bindings->argon2-cffi->notebook>=4.4.1->widgetsnbextension~=3.6.0->ipywidgets>=7.0.0->ipysankeywidget) (2.21)
Requirement already satisfied: pyparsing!=3.0.5,>=2.0.2 in ./venv_jenkins/lib/python3.9/site-packages (from packaging->bleach->nbconvert>=5->notebook>=4.4.1->widgetsnbextension~=3.6.0->ipywidgets>=7.0.0->ipysankeywidget) (3.0.7)
Installing collected packages: ipysankeywidget
Successfully installed ipysankeywidget-0.4.1

real	0m1.579s
user	0m1.038s
sys	0m0.133s
+++ pip_install plotly
+++ python /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/bin/pip install --upgrade plotly
Collecting plotly
  Using cached plotly-5.6.0-py2.py3-none-any.whl (27.7 MB)
Collecting tenacity>=6.2.0
  Using cached tenacity-8.0.1-py3-none-any.whl (24 kB)
Requirement already satisfied: six in ./venv_jenkins/lib/python3.9/site-packages (from plotly) (1.16.0)
Installing collected packages: tenacity, plotly
Successfully installed plotly-5.6.0 tenacity-8.0.1

real	0m21.221s
user	0m7.978s
sys	0m6.992s
+++ pip_install pytest
+++ python /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/bin/pip install --upgrade pytest
Collecting pytest
  Using cached pytest-7.1.1-py3-none-any.whl (297 kB)
Requirement already satisfied: attrs>=19.2.0 in ./venv_jenkins/lib/python3.9/site-packages (from pytest) (21.4.0)
Collecting tomli>=1.0.0
  Using cached tomli-2.0.1-py3-none-any.whl (12 kB)
Collecting py>=1.8.2
  Using cached py-1.11.0-py2.py3-none-any.whl (98 kB)
Collecting iniconfig
  Using cached iniconfig-1.1.1-py2.py3-none-any.whl (5.0 kB)
Requirement already satisfied: packaging in ./venv_jenkins/lib/python3.9/site-packages (from pytest) (21.3)
Collecting pluggy<2.0,>=0.12
  Using cached pluggy-1.0.0-py2.py3-none-any.whl (13 kB)
Requirement already satisfied: pyparsing!=3.0.5,>=2.0.2 in ./venv_jenkins/lib/python3.9/site-packages (from packaging->pytest) (3.0.7)
Installing collected packages: iniconfig, tomli, py, pluggy, pytest
Successfully installed iniconfig-1.1.1 pluggy-1.0.0 py-1.11.0 pytest-7.1.1 tomli-2.0.1

real	0m1.524s
user	0m1.227s
sys	0m0.204s
++++ which coverage
+++ export COVERAGE=/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/bin/coverage
+++ COVERAGE=/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/bin/coverage
++ pip_install numpy
++ python /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/bin/pip install --upgrade numpy
Requirement already satisfied: numpy in ./venv_jenkins/lib/python3.9/site-packages (1.22.3)

real	0m1.322s
user	0m1.185s
sys	0m0.103s
++ pip_install scipy
++ python /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/bin/pip install --upgrade scipy
Collecting scipy
  Using cached scipy-1.8.0-cp39-cp39-macosx_12_0_universal2.macosx_10_9_x86_64.whl (55.6 MB)
Requirement already satisfied: numpy<1.25.0,>=1.17.3 in ./venv_jenkins/lib/python3.9/site-packages (from scipy) (1.22.3)
Installing collected packages: scipy
Successfully installed scipy-1.8.0

real	0m7.611s
user	0m3.888s
sys	0m1.024s
++ pip_install pint
++ python /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/bin/pip install --upgrade pint
Collecting pint
  Using cached Pint-0.18-py2.py3-none-any.whl (209 kB)
Requirement already satisfied: packaging in ./venv_jenkins/lib/python3.9/site-packages (from pint) (21.3)
Requirement already satisfied: pyparsing!=3.0.5,>=2.0.2 in ./venv_jenkins/lib/python3.9/site-packages (from packaging->pint) (3.0.7)
Installing collected packages: pint
Successfully installed pint-0.18

real	0m1.512s
user	0m0.946s
sys	0m0.137s
++ git clone --depth 1 https://github.com/convexengineering/gpkit.git /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gpkit
Cloning into '/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gpkit'...
++ python /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/bin/pip install -v --no-cache-dir --no-deps -e /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gpkit
Using pip 22.0.4 from /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages/pip (python 3.9)
Obtaining file:///Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gpkit
  Preparing metadata (setup.py): started
  Running command python setup.py egg_info
  running egg_info
  creating /private/var/folders/qk/9zkf0syn149fvhw9mh7hgd5w0000gp/T/pip-pip-egg-info-j4llj0vq/gpkit.egg-info
  writing /private/var/folders/qk/9zkf0syn149fvhw9mh7hgd5w0000gp/T/pip-pip-egg-info-j4llj0vq/gpkit.egg-info/PKG-INFO
  writing dependency_links to /private/var/folders/qk/9zkf0syn149fvhw9mh7hgd5w0000gp/T/pip-pip-egg-info-j4llj0vq/gpkit.egg-info/dependency_links.txt
  writing requirements to /private/var/folders/qk/9zkf0syn149fvhw9mh7hgd5w0000gp/T/pip-pip-egg-info-j4llj0vq/gpkit.egg-info/requires.txt
  writing top-level names to /private/var/folders/qk/9zkf0syn149fvhw9mh7hgd5w0000gp/T/pip-pip-egg-info-j4llj0vq/gpkit.egg-info/top_level.txt
  writing manifest file '/private/var/folders/qk/9zkf0syn149fvhw9mh7hgd5w0000gp/T/pip-pip-egg-info-j4llj0vq/gpkit.egg-info/SOURCES.txt'
  reading manifest file '/private/var/folders/qk/9zkf0syn149fvhw9mh7hgd5w0000gp/T/pip-pip-egg-info-j4llj0vq/gpkit.egg-info/SOURCES.txt'
  adding license file 'LICENSE'
  writing manifest file '/private/var/folders/qk/9zkf0syn149fvhw9mh7hgd5w0000gp/T/pip-pip-egg-info-j4llj0vq/gpkit.egg-info/SOURCES.txt'
  Preparing metadata (setup.py): finished with status 'done'
Installing collected packages: gpkit
  Running setup.py develop for gpkit
    Running command python setup.py develop
    running develop
    /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages/setuptools/command/easy_install.py:160: EasyInstallDeprecationWarning: easy_install command is deprecated. Use build and pip and other standards-based tools.
      warnings.warn(
    /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages/setuptools/command/install.py:34: SetuptoolsDeprecationWarning: setup.py install is deprecated. Use build and pip and other standards-based tools.
      warnings.warn(
    running egg_info
    creating gpkit.egg-info
    writing gpkit.egg-info/PKG-INFO
    writing dependency_links to gpkit.egg-info/dependency_links.txt
    writing requirements to gpkit.egg-info/requires.txt
    writing top-level names to gpkit.egg-info/top_level.txt
    writing manifest file 'gpkit.egg-info/SOURCES.txt'
    reading manifest file 'gpkit.egg-info/SOURCES.txt'
    adding license file 'LICENSE'
    writing manifest file 'gpkit.egg-info/SOURCES.txt'
    running build_ext
    Creating /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages/gpkit.egg-link (link to .)
    Adding gpkit 1.1.1 to easy-install.pth file

    Installed /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gpkit
Successfully installed gpkit-1.1.1
++ source /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/JenkinsGPkit/print_versions.sh
+++ python -c 'import scipy; print(scipy.__version__)'
1.8.0
+++ python -c 'import numpy; print(numpy.__version__)'
1.22.3
+++ python -c 'import pint; print(pint.__version__)'
0.18
+++ python -c 'import gpkit; print(gpkit.settings)'
/bin/sh: mskexpopt: command not found
No filename given.
Usage:
     mskexpopt FILENAME [-primal] [-dual] [-p parameterfile]
Return code: 1052
Description: MSK_RES_ERR_FILE_OPEN [An error occurred while opening a file.]
/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gpkit/gpkit/small_scripts.py:71: SyntaxWarning: "is" with a literal. Did you mean "=="?
  if sweep is "sweep" and (isinstance(value, Iterable) or  # pylint: disable=literal-comparison
/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gpkit/gpkit/nomials/math.py:586: SyntaxWarning: "is" with a literal. Did you mean "=="?
  if posy is 0:  # pylint: disable=literal-comparison
/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gpkit/gpkit/nomials/math.py:590: SyntaxWarning: "is" with a literal. Did you mean "=="?
  if negy is 0:  # pylint: disable=literal-comparison
/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gpkit/gpkit/breakdowns.py:390: SyntaxWarning: "is" with a literal. Did you mean "=="?
  subhmap.units = None if units is 1 else units
.................................................................................................................................................................................................................
----------------------------------------------------------------------
Ran 209 tests in 10.455s

OK
Found no installed solvers, beginning a build.
# Building GPkit version 1.1
# Moving to the directory from which GPkit was imported.

Attempting to find and build solvers:

# Looking for `mosek_cli`
#   (A "success" is if mskexpopt complains that
#    we haven't specified a file for it to open.)
#     Calling 'mskexpopt'
##
### CALL BEGINS
### CALL ENDS
##
# Looks like `mskexpopt` was not found in the default PATH,
#  so let's try locating that binary ourselves.
#   Adding /Users/jenkins/mosek/8/tools/platform/osx64x86/bin to the PATH
#     Calling 'mskexpopt'
##
### CALL BEGINS
### CALL ENDS
##

Found mosek_cli in /Users/jenkins/mosek/8/tools/platform/osx64x86/bin

# Looking for `mosek_conif`
#   Trying to import mosek...
# Did not find
# mosek_conif

# Looking for `cvxopt`
#   Trying to import cvxopt...

Found cvxopt in the default PYTHONPATH
Replaced found solvers (['mosek_cli', 'cvxopt']) with environment var GPKITSOLVERS (cvxopt)

Found the following solvers: cvxopt
#     Replacing directory env

GPkit is now installed with solver(s) ['cvxopt']
To incorporate new solvers at a later date, run `gpkit.build()`.

If any tests didn't pass, please post the output above
(starting from "Found no installed solvers, beginning a build.")
to gpkit@mit.edu or https://github.com/convexengineering/gpkit/issues/new
so we can prevent others from having these errors.

The same goes for any other bugs you encounter with GPkit:
send 'em our way, along with any interesting models, speculative features,
comments, discussions, or clarifications you feel like sharing.

Finally, we hope you find our documentation (https://gpkit.readthedocs.io/)
and engineering-design models (https://github.com/convexengineering/gplibrary/)
to be useful resources for your own applications.

Enjoy!

{'installed_solvers': ['cvxopt'], 'mosek_bin_dir': '/Users/jenkins/mosek/8/tools/platform/osx64x86/bin', 'default_solver': 'cvxopt', 'just built!': True}
++ export MSK_IPAR_NUM_THREADS=2
++ MSK_IPAR_NUM_THREADS=2
++ export MKL_NUM_THREADS=2
++ MKL_NUM_THREADS=2
++ export NUMEXPR_NUM_THREADS=2
++ NUMEXPR_NUM_THREADS=2
++ export OPENBLAS_NUM_THREADS=2
++ OPENBLAS_NUM_THREADS=2
++ export OMP_NUM_THREADS=2
++ OMP_NUM_THREADS=2
++ python -c 'from gpkit.tests.test_repo import test_repos; test_repos(xmloutput=True, ingpkitmodels=True)'
Obtaining file:///Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Installing collected packages: gpkitmodels
  Running setup.py develop for gpkitmodels
Successfully installed gpkitmodels
Cloning into 'SPaircraft'...
Collecting git+https://github.com/hoburg/turbofan.git
  Cloning https://github.com/hoburg/turbofan.git to /private/var/folders/qk/9zkf0syn149fvhw9mh7hgd5w0000gp/T/pip-req-build-lnqdpv4o
  Running command git clone --filter=blob:none --quiet https://github.com/hoburg/turbofan.git /private/var/folders/qk/9zkf0syn149fvhw9mh7hgd5w0000gp/T/pip-req-build-lnqdpv4o
  Resolved https://github.com/hoburg/turbofan.git to commit 4ebac5743e608d110117dc34537add84f63ccd19
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Requirement already satisfied: numpy in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from turbofan==0.0.0.0) (1.22.3)
Requirement already satisfied: scipy in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from turbofan==0.0.0.0) (1.8.0)
Requirement already satisfied: pint in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from turbofan==0.0.0.0) (0.18)
Collecting future
  Using cached future-0.18.2-py3-none-any.whl
Requirement already satisfied: packaging in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pint->turbofan==0.0.0.0) (21.3)
Requirement already satisfied: pyparsing!=3.0.5,>=2.0.2 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from packaging->pint->turbofan==0.0.0.0) (3.0.7)
Building wheels for collected packages: turbofan
  Building wheel for turbofan (setup.py): started
  Building wheel for turbofan (setup.py): finished with status 'done'
  Created wheel for turbofan: filename=turbofan-0.0.0.0-py3-none-any.whl size=43849 sha256=29828373646fd9a488757e724d5c447d5c65405646fbdec7c5d503a70d623977
  Stored in directory: /private/var/folders/qk/9zkf0syn149fvhw9mh7hgd5w0000gp/T/pip-ephem-wheel-cache-9r68p8de/wheels/d7/9f/b9/a8875d37f2740d561f7ca84d6af59091975c6b21d1b7f0369c
Successfully built turbofan
Installing collected packages: future, turbofan
Successfully installed future-0.18.2 turbofan-0.0.0.0
Processing /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/SPaircraft
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Requirement already satisfied: turbofan in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from SPaircraft==0.0.0) (0.0.0.0)
Requirement already satisfied: gpkit in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gpkit (from SPaircraft==0.0.0) (1.1.1)
Requirement already satisfied: future in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from SPaircraft==0.0.0) (0.18.2)
Requirement already satisfied: numpy>=1.16.4 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkit->SPaircraft==0.0.0) (1.22.3)
Requirement already satisfied: pint>=0.8.1 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkit->SPaircraft==0.0.0) (0.18)
Requirement already satisfied: plotly in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkit->SPaircraft==0.0.0) (5.6.0)
Requirement already satisfied: scipy in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkit->SPaircraft==0.0.0) (1.8.0)
Requirement already satisfied: adce in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkit->SPaircraft==0.0.0) (1.3.3.2)
Requirement already satisfied: cvxopt>=1.1.8 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkit->SPaircraft==0.0.0) (1.3.0)
Requirement already satisfied: matplotlib in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkit->SPaircraft==0.0.0) (3.5.1)
Requirement already satisfied: packaging in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pint>=0.8.1->gpkit->SPaircraft==0.0.0) (21.3)
Requirement already satisfied: cycler>=0.10 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib->gpkit->SPaircraft==0.0.0) (0.11.0)
Requirement already satisfied: kiwisolver>=1.0.1 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib->gpkit->SPaircraft==0.0.0) (1.4.2)
Requirement already satisfied: pillow>=6.2.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib->gpkit->SPaircraft==0.0.0) (9.0.1)
Requirement already satisfied: pyparsing>=2.2.1 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib->gpkit->SPaircraft==0.0.0) (3.0.7)
Requirement already satisfied: fonttools>=4.22.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib->gpkit->SPaircraft==0.0.0) (4.31.2)
Requirement already satisfied: python-dateutil>=2.7 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib->gpkit->SPaircraft==0.0.0) (2.8.2)
Requirement already satisfied: tenacity>=6.2.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from plotly->gpkit->SPaircraft==0.0.0) (8.0.1)
Requirement already satisfied: six in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from plotly->gpkit->SPaircraft==0.0.0) (1.16.0)
Building wheels for collected packages: SPaircraft
  Building wheel for SPaircraft (setup.py): started
  Building wheel for SPaircraft (setup.py): finished with status 'done'
  Created wheel for SPaircraft: filename=SPaircraft-0.0.0-py3-none-any.whl size=1771 sha256=ba77e05493c0cbfb343fe320f944a850953c054d14a9dadc6629b21010a76b66
  Stored in directory: /private/var/folders/qk/9zkf0syn149fvhw9mh7hgd5w0000gp/T/pip-ephem-wheel-cache-qt8j0uyo/wheels/c3/76/b7/d95f9641acc2f91ba5cd0f47409c244b27a42214f4b4e294b7
Successfully built SPaircraft
Installing collected packages: SPaircraft
Successfully installed SPaircraft-0.0.0

Running tests...
----------------------------------------------------------------------
adding test for 'SPaircraft.py'
.
----------------------------------------------------------------------
Ran 1 test in 0.001s

OK

Generating XML reports...
Cloning into 'robust'...
Processing /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/robust
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Requirement already satisfied: gpkit in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gpkit (from robust==0.0.0) (1.1.1)
ERROR: Could not find a version that satisfies the requirement gplibrary (from robust) (from versions: none)
ERROR: No matching distribution found for gplibrary
Processing /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/robust
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Requirement already satisfied: gpkit in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gpkit (from robust==0.0.0) (1.1.1)
ERROR: Could not find a version that satisfies the requirement gplibrary (from robust) (from versions: none)
ERROR: No matching distribution found for gplibrary
Processing /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/robust
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Requirement already satisfied: gpkit in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gpkit (from robust==0.0.0) (1.1.1)
ERROR: Could not find a version that satisfies the requirement gplibrary (from robust) (from versions: none)
ERROR: No matching distribution found for gplibrary
Processing /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/robust
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Requirement already satisfied: gpkit in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gpkit (from robust==0.0.0) (1.1.1)
ERROR: Could not find a version that satisfies the requirement gplibrary (from robust) (from versions: none)
ERROR: No matching distribution found for gplibrary
Processing /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/robust
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Requirement already satisfied: gpkit in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gpkit (from robust==0.0.0) (1.1.1)
ERROR: Could not find a version that satisfies the requirement gplibrary (from robust) (from versions: none)
ERROR: No matching distribution found for gplibrary

Running tests...
----------------------------------------------------------------------
adding test for 'run_tests.py'

Running tests...
----------------------------------------------------------------------
.F..........FF..F....
======================================================================
FAIL [0.021s]: test_correlated_monomials (run_tests.TestEquivalentPosynomials_cvxopt)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/robust/robust/testing/t_equivalent_posynomials.py", line 99, in test_correlated_monomials
    self.assertSetEqual(set(actual_posynomials), set(theoretical_posynomials))
AssertionError: Items in the first set but not the second:
gpkit.Posynomial(x_11^0.66·x_6^0.99·x_4^2.2·x_1^2.8·x_5^3.2·x_8^4.2·x_7^4.2/x_10^5/x_9^4.1/x_2^4/x_3^1.9/x_0^0.19 + x_3^1.5·x_6^1.6·x_9^2.4·x_1^4.1·x_2^4.5·x_8^4.9/x_7^4.5/x_5^4.5/x_4^0.77/x_0^0.75/x_10^0.53/x_11^0.16 + x_8^0.3·x_10^0.46·x_2^1·x_4^2·x_3^2·x_11^2.1·x_6^3.3·x_7^4.1/u_1^4.6/x_5^4.5/x_9^3.9/x_1^3.7/x_0^0.84 + u_1^0.34·x_3^1.3·u_2^1.6·x_2^2.3·x_11^2.7·x_8^3.2·x_1^3.5·x_7^4.7·x_9^4.8/x_10^2.8/x_6^2.2/x_0^1.8/x_5^1.7/x_4^0.058 + x_1^0.14·x_11^1.2·x_10^3.5·x_9^4.8/x_2^4.6/x_4^4.4/x_7^3.6/x_8^2.1/x_0^1.9/x_5^1.1/x_6^1/x_3^0.83 + x_10^0.99·x_3^1.2·u_1^1.6·x_6^1.6·x_1^3.1·x_9^3.4·x_8^3.7·x_5^4.3/x_7^2.8/x_4^2.6/x_0^2.4/x_2^1.7/x_11^1.4 + x_1^0.69·x_6^0.83·x_8^1.5·x_10^2.8·x_5^3.6·x_3^4.2/x_2^4.4/x_9^4/x_0^2.9/x_7^2.3/x_4^1.6/x_11^0.23 + x_8^1·x_2^1.9·x_7^2.8/x_5^4.5/x_1^3.7/x_6^3.5/x_4^3.5/x_9^3.3/x_10^3.1/x_0^3/x_3^1.6/x_11^0.56 + x_3^0.64·u_1^1.5·x_5^3.1·x_11^3.8·x_6^3.9·x_7^4.5·x_4^4.8/x_8^5/x_2^3.5/x_0^3.2/x_10^3.1/x_9^2.7/x_1^0.21/u_0^0.095 + x_2^0.1·x_7^0.59·x_8^2.7·x_4^3.8·x_9^4.5/x_3^4.8/x_10^4.6/x_0^4/x_6^3.3/x_11^3.1/x_1^1.9/x_5^0.72 + x_10^1.1·x_3^4.1·x_7^4.5/x_4^4.6/x_0^4.4/x_1^4.2/x_5^3.8/x_11^3.6/x_2^2.6/x_8^2.3/u_0^2/x_6^0.26/x_9^0.14 + x_1^0.78·x_11^1.2·u_0^1.7·x_6^2·x_8^2.1·x_4^2.9·x_10^3.5·x_9^4.3/x_0^4.8/x_7^3.7/x_3^3.6/x_5^3.5/x_2^2.2/u_2^1.9 + x_10^0.024·x_7^0.37·u_0^0.42·x_4^1.5·x_0^1.8·x_2^2.2·x_6^2.6·x_5^2.6·u_2^4.7/x_8^4.4/x_11^2.9/x_1^1.6/x_3^0.9/x_9^0.87 + x_9^0.3·u_2^1·x_0^1.8·x_4^2.3·x_8^2.5·x_3^3·x_6^3.1·x_10^3.1·x_7^3.6·x_1^3.9/x_5^3.1/x_2^2.1/x_11^1.9 + u_0^0.11·x_3^1.3·x_4^1.4·x_0^1.8·x_8^2.7·x_7^3.3·x_1^3.6·x_10^3.8·x_5^4.7/x_2^3.4/x_6^2.3/x_9^1.7/x_11^0.36 + x_5^0.042·x_6^0.18·x_1^1.1·x_9^2.9·x_0^4.1·x_3^4.1/x_2^4.5/x_10^4.1/x_8^2.7/x_4^2.7/x_7^1.1/x_11^0.066)
Items in the second set but not the first:
gpkit.Posynomial(u_0^0.11·x_3^1.3·x_4^1.4·x_0^1.8·x_8^2.7·x_7^3.3·x_1^3.6·x_10^3.8·x_5^4.7/x_2^3.4/x_6^2.3/x_9^1.7/x_11^0.36 + x_0^-2.1218462131993263·x_1^0.0981963542771016·x_2^3.110269852671637·x_3^1.535642351533017·x_4^4.213017478377557·x_5^3.381466944571004·x_6^1.7949087708599034·x_7^3.417361108327645·x_8^-4.975658129618435·x_9^-4.5556764933501634·x_10^1.1882803802200748·x_11^-4.82703286827981·u_0^0.0·u_1^2.1331670531410643·u_2^0.0 + x_0^0.07286241183175157·x_1^0.5396249386667105·x_2^4.416554569161512·x_3^0.506207802015207·x_4^-1.4494125240111022·x_5^3.4258987980408513·x_6^-4.303749722326128·x_7^-2.976117855136983·x_8^-2.985931813320517·x_9^-3.158783333744285·x_10^-1.2966279246633974·x_11^-4.706557932989005·u_0^0.0·u_1^4.7920151648437574·u_2^0.0 + x_0^-4.806611757634376·x_1^0.7762585370182595·x_2^-2.2009561735152614·x_3^-3.639070389710616·x_4^2.8751617474381437·x_5^-3.4967590215697255·x_6^2.0035449912205197·x_7^-3.662839103291261·x_8^2.1142429926033666·x_9^4.286358371784514·x_10^3.4523941473871744·x_11^1.1704262859711587·u_0^1.6552684244245626·u_1^0.0·u_2^-1.8869141246549048 + x_0^-0.8422143149194019·x_1^-3.704350205199991·x_2^1.011723083222802·x_3^1.9844660048569125·x_4^1.9546837612989165·x_5^-4.517468898054346·x_6^3.2672257002319753·x_7^4.134574715215113·x_8^0.30357317657242966·x_9^-3.859075984807052·x_10^0.45809647960661515·x_11^2.1190313802198624·u_0^0.0·u_1^-4.623793956686947·u_2^0.0 + x_0^-0.18310940468180803·x_1^0.6815738207995352·x_2^-4.770718841328638·x_3^-0.30873824087461443·x_4^-2.420862810094625·x_5^3.52623831141479·x_6^-1.4711672289277287·x_7^-1.89144881501102·x_8^1.1611972392578807·x_9^2.650245745892673·x_10^2.870254998071653·x_11^-1.6891760951930692·u_0^0.24250982720216752·u_1^0.0·u_2^0.0 + x_0^-0.009884496086569605·x_1^4.277502904236556·x_2^-2.863861277993913·x_3^3.6533793335979468·x_4^4.1079170223037025·x_5^1.6395792479587001·x_6^3.4536956673923456·x_7^-2.8273914260430866·x_8^-3.4658558396158434·x_9^4.059456786500437·x_10^1.619492790326448·x_11^0.4505695918965156·u_0^0.0·u_1^-0.8230577782363618·u_2^4.179777966007002 + x_0^-3.221338954792947·x_1^-0.2067908517126371·x_2^-3.5420986944102397·x_3^0.6376031196511525·x_4^4.849267928264457·x_5^3.0830955020695257·x_6^3.8729482392815058·x_7^4.504603169925224·x_8^-4.972722077142557·x_9^-2.653833762576973·x_10^-3.1116824582548452·x_11^3.840979153379152·u_0^-0.09457796162535115·u_1^1.5348121947526183·u_2^0.0 + x_0^2.2239971255607225·x_1^2.922196532597786·x_2^-2.303305332152814·x_3^4.111941461733737·x_4^3.992670782535839·x_5^-2.1225102991849285·x_6^-3.201276817296257·x_7^0.13036452707921065·x_8^-4.653729062187383·x_9^0.5768034853005037·x_10^3.105380020668857·x_11^-1.1587652144794447·u_0^0.0·u_1^-0.1601351517875521·u_2^0.0 + x_0^-1.7861835295185369·x_1^3.488591784940743·x_2^2.3279536647587387·x_3^1.3262231407846592·x_4^-0.05769418080311084·x_5^-1.6817381748831473·x_6^-2.19040487790072·x_7^4.745194748997134·x_8^3.189525896874363·x_9^4.8146415061121335·x_10^-2.8161865914655015·x_11^2.7334342956996043·u_0^0.0·u_1^0.34330642153654056·u_2^1.5618676652622776 + x_0^-2.042080148962965·x_1^1.32445792077168·x_2^-4.436539003885178·x_3^-1.5011425220212704·x_4^-2.069648277111631·x_5^-4.336814105992509·x_6^0.1711021048373098·x_7^2.1457587493256733·x_8^-1.785875387053899·x_9^-1.3051183814616385·x_10^0.4213005805595573·x_11^3.284176112490025·u_0^-1.4277291790979691·u_1^0.0·u_2^0.0 + x_0^1.7715088785414128·x_1^-1.5601546979317114·x_2^2.238029564051872·x_3^-0.9006715092547202·x_4^1.52863133498626·x_5^2.621900926946248·x_6^2.597738296276467·x_7^0.36824144828058536·x_8^-4.375769036545795·x_9^-0.8714371865836679·x_10^0.023502598608793335·x_11^-2.909829973479402·u_0^0.4231352633991736·u_1^0.0·u_2^4.676080418003953 + x_0^-4.411918255869795·x_1^-4.234327727948805·x_2^-2.6189003230573604·x_3^4.0721116242678495·x_4^-4.625130918438294·x_5^-3.844169849565179·x_6^-0.26464938069604127·x_7^4.522684676951203·x_8^-2.310364858806828·x_9^-0.13934856543102647·x_10^1.1141117878132594·x_11^-3.5862529576621807·u_0^-2.0092639910921886·u_1^0.0·u_2^0.0 + x_0^1.785716140914058·x_1^3.9027231434578304·x_2^-2.132268276047423·x_3^3.0176055247724207·x_4^2.283467231720029·x_5^-3.052467260187578·x_6^3.0643137781992564·x_7^3.613838295638308·x_8^2.4564619853492466·x_9^0.3046201248529954·x_10^3.0907388819619417·x_11^-1.8925140186871001·u_0^0.0·u_1^0.0·u_2^1.004870007141273 + x_0^1.964184428623522·x_1^2.169897643412919·x_2^-0.09224077641562545·x_3^3.499809695998618·x_4^-1.592718113284323·x_5^-2.5897590195291267·x_6^2.643982231455775·x_7^1.376746550312797·x_8^-2.5338473393947325·x_9^2.5666348523442704·x_10^4.41083239375306·x_11^2.546318452539266·u_0^1.200290953684101·u_1^0.0·u_2^0.0 + x_0^-2.3914309591945715·x_1^3.051303316814934·x_2^-1.7203868526252153·x_3^1.177526985265846·x_4^-2.5941008788810427·x_5^4.346552951537539·x_6^1.622296849889091·x_7^-2.808309611606965·x_8^3.6842028498928254·x_9^3.377978520358564·x_10^0.9894922023849206·x_11^-1.3921314091170944·u_0^0.0·u_1^1.6079863774414478·u_2^0.0)

======================================================================
FAIL [0.220s]: test_conservativeness (run_tests.TestPrimitives_cvxopt)
Testing conservativeness of solution methods
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/robust/robust/testing/t_primitives.py", line 66, in test_conservativeness
    self.assertTrue(sm['cost'] <= sem['cost'] <= smm['cost'] <= sbm['cost'])
AssertionError: False is not true

======================================================================
FAIL [0.037s]: test_methods (run_tests.TestPrimitives_cvxopt)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/robust/robust/testing/t_primitives.py", line 117, in test_methods
    self.assertAlmostEqual(sol(vk), prev_sol(vk), places=5)
AssertionError: <Quantity(0.636130631, 'dimensionless')> != <Quantity(0.631384596, 'dimensionless')> within 5 places (<Quantity(0.0047460356, 'dimensionless')> difference)

======================================================================
FAIL [1.164s]: test_bad_relations (run_tests.TestTwoTermApproximation_cvxopt)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/robust/robust/testing/t_two_term_approximation.py", line 202, in test_bad_relations
    self.assertEqual(actual_relations_mons, relations_mons)
AssertionError: {gpkit.Monomial(5.02·u_95^0.89·u_19^1.1·u_31^1.2·u_39^1.2[106232 chars] 15}} != {gpkit.Monomial(7.63·x_0^-4.1766200009783185·u_0^4.375230[320343 chars] 15}}
Diff is 780552 characters long. Set self.maxDiff to None to see it.

----------------------------------------------------------------------
Ran 21 tests in 9.583s

FAILED (failures=4)

Generating XML reports...
.
----------------------------------------------------------------------
Ran 1 test in 24.167s

OK

Generating XML reports...
Cloning into 'shopping'...

Running tests...
----------------------------------------------------------------------
adding test for 'test.py'
..Using solver 'cvxopt'
 for 25 free variables
  in 40 posynomial inequalities.
Solving took 0.0375 seconds.
Using solver 'cvxopt'
 for 25 free variables
  in 40 posynomial inequalities.
Solving took 0.0164 seconds.

----------------------------------------------------------------------
Ran 2 tests in 0.095s

OK

Generating XML reports...
Cloning into 'gassolar'...
Requirement already satisfied: pandas in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (1.4.1)
Requirement already satisfied: pytz>=2020.1 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pandas) (2022.1)
Requirement already satisfied: python-dateutil>=2.8.1 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pandas) (2.8.2)
Requirement already satisfied: numpy>=1.18.5 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pandas) (1.22.3)
Requirement already satisfied: six>=1.5 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from python-dateutil>=2.8.1->pandas) (1.16.0)
Collecting git+https://github.com/hoburg/gpfit.git
  Cloning https://github.com/hoburg/gpfit.git to /private/var/folders/qk/9zkf0syn149fvhw9mh7hgd5w0000gp/T/pip-req-build-1jp7fbfo
  Running command git clone --filter=blob:none --quiet https://github.com/hoburg/gpfit.git /private/var/folders/qk/9zkf0syn149fvhw9mh7hgd5w0000gp/T/pip-req-build-1jp7fbfo
  Resolved https://github.com/hoburg/gpfit.git to commit 3c8025f12ba5360fdeb71c270e55d4c93e1676fd
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Requirement already satisfied: numpy in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpfit==0.2.0) (1.22.3)
Requirement already satisfied: scipy in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpfit==0.2.0) (1.8.0)
Requirement already satisfied: gpkit in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gpkit (from gpfit==0.2.0) (1.1.1)
Requirement already satisfied: matplotlib>=3.3.2 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpfit==0.2.0) (3.5.1)
Requirement already satisfied: pytest>=6.2.5 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpfit==0.2.0) (7.1.1)
Collecting pytest-mpl>=0.13
  Using cached pytest_mpl-0.14.0-py3-none-any.whl (27 kB)
Requirement already satisfied: pillow>=6.2.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit==0.2.0) (9.0.1)
Requirement already satisfied: python-dateutil>=2.7 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit==0.2.0) (2.8.2)
Requirement already satisfied: fonttools>=4.22.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit==0.2.0) (4.31.2)
Requirement already satisfied: pyparsing>=2.2.1 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit==0.2.0) (3.0.7)
Requirement already satisfied: packaging>=20.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit==0.2.0) (21.3)
Requirement already satisfied: cycler>=0.10 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit==0.2.0) (0.11.0)
Requirement already satisfied: kiwisolver>=1.0.1 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit==0.2.0) (1.4.2)
Requirement already satisfied: attrs>=19.2.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest>=6.2.5->gpfit==0.2.0) (21.4.0)
Requirement already satisfied: tomli>=1.0.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest>=6.2.5->gpfit==0.2.0) (2.0.1)
Requirement already satisfied: py>=1.8.2 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest>=6.2.5->gpfit==0.2.0) (1.11.0)
Requirement already satisfied: iniconfig in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest>=6.2.5->gpfit==0.2.0) (1.1.1)
Requirement already satisfied: pluggy<2.0,>=0.12 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest>=6.2.5->gpfit==0.2.0) (1.0.0)
Requirement already satisfied: Jinja2 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest-mpl>=0.13->gpfit==0.2.0) (3.1.1)
Requirement already satisfied: pint>=0.8.1 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkit->gpfit==0.2.0) (0.18)
Requirement already satisfied: plotly in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkit->gpfit==0.2.0) (5.6.0)
Requirement already satisfied: adce in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkit->gpfit==0.2.0) (1.3.3.2)
Requirement already satisfied: cvxopt>=1.1.8 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkit->gpfit==0.2.0) (1.3.0)
Requirement already satisfied: six>=1.5 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from python-dateutil>=2.7->matplotlib>=3.3.2->gpfit==0.2.0) (1.16.0)
Requirement already satisfied: MarkupSafe>=2.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from Jinja2->pytest-mpl>=0.13->gpfit==0.2.0) (2.1.1)
Requirement already satisfied: tenacity>=6.2.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from plotly->gpkit->gpfit==0.2.0) (8.0.1)
Building wheels for collected packages: gpfit
  Building wheel for gpfit (setup.py): started
  Building wheel for gpfit (setup.py): finished with status 'done'
  Created wheel for gpfit: filename=gpfit-0.2.0-py3-none-any.whl size=493939 sha256=097d4b4bce11f21308c11856e409d4d90b8cb0e27f773c2f27ec2a5981fd2a0e
  Stored in directory: /private/var/folders/qk/9zkf0syn149fvhw9mh7hgd5w0000gp/T/pip-ephem-wheel-cache-k0mrlfkd/wheels/7d/c7/e2/9c7f9a2bc07099a39824267dca90eb5f2bc4114dcffca7aced
Successfully built gpfit
Installing collected packages: pytest-mpl, gpfit
Successfully installed gpfit-0.2.0 pytest-mpl-0.14.0
Processing /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gassolar
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Requirement already satisfied: numpy in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gassolar==0.0.0.0) (1.22.3)
Requirement already satisfied: scipy in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gassolar==0.0.0.0) (1.8.0)
Requirement already satisfied: gpkit in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gpkit (from gassolar==0.0.0.0) (1.1.1)
Requirement already satisfied: pandas in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gassolar==0.0.0.0) (1.4.1)
Requirement already satisfied: gpfit in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gassolar==0.0.0.0) (0.2.0)
Requirement already satisfied: matplotlib>=3.3.2 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpfit->gassolar==0.0.0.0) (3.5.1)
Requirement already satisfied: pytest>=6.2.5 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpfit->gassolar==0.0.0.0) (7.1.1)
Requirement already satisfied: pytest-mpl>=0.13 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpfit->gassolar==0.0.0.0) (0.14.0)
Requirement already satisfied: pint>=0.8.1 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkit->gassolar==0.0.0.0) (0.18)
Requirement already satisfied: plotly in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkit->gassolar==0.0.0.0) (5.6.0)
Requirement already satisfied: adce in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkit->gassolar==0.0.0.0) (1.3.3.2)
Requirement already satisfied: cvxopt>=1.1.8 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkit->gassolar==0.0.0.0) (1.3.0)
Requirement already satisfied: python-dateutil>=2.8.1 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pandas->gassolar==0.0.0.0) (2.8.2)
Requirement already satisfied: pytz>=2020.1 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pandas->gassolar==0.0.0.0) (2022.1)
Requirement already satisfied: fonttools>=4.22.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit->gassolar==0.0.0.0) (4.31.2)
Requirement already satisfied: pyparsing>=2.2.1 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit->gassolar==0.0.0.0) (3.0.7)
Requirement already satisfied: packaging>=20.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit->gassolar==0.0.0.0) (21.3)
Requirement already satisfied: kiwisolver>=1.0.1 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit->gassolar==0.0.0.0) (1.4.2)
Requirement already satisfied: pillow>=6.2.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit->gassolar==0.0.0.0) (9.0.1)
Requirement already satisfied: cycler>=0.10 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit->gassolar==0.0.0.0) (0.11.0)
Requirement already satisfied: py>=1.8.2 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest>=6.2.5->gpfit->gassolar==0.0.0.0) (1.11.0)
Requirement already satisfied: iniconfig in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest>=6.2.5->gpfit->gassolar==0.0.0.0) (1.1.1)
Requirement already satisfied: attrs>=19.2.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest>=6.2.5->gpfit->gassolar==0.0.0.0) (21.4.0)
Requirement already satisfied: pluggy<2.0,>=0.12 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest>=6.2.5->gpfit->gassolar==0.0.0.0) (1.0.0)
Requirement already satisfied: tomli>=1.0.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest>=6.2.5->gpfit->gassolar==0.0.0.0) (2.0.1)
Requirement already satisfied: Jinja2 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest-mpl>=0.13->gpfit->gassolar==0.0.0.0) (3.1.1)
Requirement already satisfied: six>=1.5 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from python-dateutil>=2.8.1->pandas->gassolar==0.0.0.0) (1.16.0)
Requirement already satisfied: tenacity>=6.2.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from plotly->gpkit->gassolar==0.0.0.0) (8.0.1)
Requirement already satisfied: MarkupSafe>=2.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from Jinja2->pytest-mpl>=0.13->gpfit->gassolar==0.0.0.0) (2.1.1)
Building wheels for collected packages: gassolar
  Building wheel for gassolar (setup.py): started
  Building wheel for gassolar (setup.py): finished with status 'done'
  Created wheel for gassolar: filename=gassolar-0.0.0.0-py3-none-any.whl size=4876528 sha256=86e3c215fe734716ceea0186c0100472f0124c8b229133f532609105fd126c9f
  Stored in directory: /private/var/folders/qk/9zkf0syn149fvhw9mh7hgd5w0000gp/T/pip-ephem-wheel-cache-wnozw85d/wheels/9a/30/67/f2f18803bc8d1bd88d08ccaf75c6b30b2d2b23b6babc1f9bfe
Successfully built gassolar
Installing collected packages: gassolar
Successfully installed gassolar-0.0.0.0

Running tests...
----------------------------------------------------------------------
adding test for 'gassolar/gas/gas.py'
adding test for 'gassolar/solar/solar.py'
.
----------------------------------------------------------------------
Ran 1 test in 0.001s

OK

Generating XML reports...
Cloning into 'jho'...
Requirement already satisfied: pandas in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (1.4.1)
Requirement already satisfied: numpy>=1.18.5 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pandas) (1.22.3)
Requirement already satisfied: python-dateutil>=2.8.1 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pandas) (2.8.2)
Requirement already satisfied: pytz>=2020.1 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pandas) (2022.1)
Requirement already satisfied: six>=1.5 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from python-dateutil>=2.8.1->pandas) (1.16.0)
Collecting git+https://github.com/hoburg/gpfit.git
  Cloning https://github.com/hoburg/gpfit.git to /private/var/folders/qk/9zkf0syn149fvhw9mh7hgd5w0000gp/T/pip-req-build-ume0b_0x
  Running command git clone --filter=blob:none --quiet https://github.com/hoburg/gpfit.git /private/var/folders/qk/9zkf0syn149fvhw9mh7hgd5w0000gp/T/pip-req-build-ume0b_0x
  Resolved https://github.com/hoburg/gpfit.git to commit 3c8025f12ba5360fdeb71c270e55d4c93e1676fd
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Requirement already satisfied: numpy in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpfit==0.2.0) (1.22.3)
Requirement already satisfied: scipy in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpfit==0.2.0) (1.8.0)
Requirement already satisfied: gpkit in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gpkit (from gpfit==0.2.0) (1.1.1)
Requirement already satisfied: matplotlib>=3.3.2 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpfit==0.2.0) (3.5.1)
Requirement already satisfied: pytest>=6.2.5 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpfit==0.2.0) (7.1.1)
Requirement already satisfied: pytest-mpl>=0.13 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpfit==0.2.0) (0.14.0)
Requirement already satisfied: fonttools>=4.22.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit==0.2.0) (4.31.2)
Requirement already satisfied: pillow>=6.2.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit==0.2.0) (9.0.1)
Requirement already satisfied: python-dateutil>=2.7 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit==0.2.0) (2.8.2)
Requirement already satisfied: packaging>=20.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit==0.2.0) (21.3)
Requirement already satisfied: cycler>=0.10 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit==0.2.0) (0.11.0)
Requirement already satisfied: kiwisolver>=1.0.1 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit==0.2.0) (1.4.2)
Requirement already satisfied: pyparsing>=2.2.1 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit==0.2.0) (3.0.7)
Requirement already satisfied: tomli>=1.0.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest>=6.2.5->gpfit==0.2.0) (2.0.1)
Requirement already satisfied: py>=1.8.2 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest>=6.2.5->gpfit==0.2.0) (1.11.0)
Requirement already satisfied: attrs>=19.2.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest>=6.2.5->gpfit==0.2.0) (21.4.0)
Requirement already satisfied: pluggy<2.0,>=0.12 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest>=6.2.5->gpfit==0.2.0) (1.0.0)
Requirement already satisfied: iniconfig in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest>=6.2.5->gpfit==0.2.0) (1.1.1)
Requirement already satisfied: Jinja2 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest-mpl>=0.13->gpfit==0.2.0) (3.1.1)
Requirement already satisfied: pint>=0.8.1 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkit->gpfit==0.2.0) (0.18)
Requirement already satisfied: plotly in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkit->gpfit==0.2.0) (5.6.0)
Requirement already satisfied: adce in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkit->gpfit==0.2.0) (1.3.3.2)
Requirement already satisfied: cvxopt>=1.1.8 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkit->gpfit==0.2.0) (1.3.0)
Requirement already satisfied: six>=1.5 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from python-dateutil>=2.7->matplotlib>=3.3.2->gpfit==0.2.0) (1.16.0)
Requirement already satisfied: MarkupSafe>=2.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from Jinja2->pytest-mpl>=0.13->gpfit==0.2.0) (2.1.1)
Requirement already satisfied: tenacity>=6.2.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from plotly->gpkit->gpfit==0.2.0) (8.0.1)

Running tests...
----------------------------------------------------------------------
adding test for 'model/jho.py'
adding test for 'model/print_perf.py'
.
----------------------------------------------------------------------
Ran 1 test in 0.001s

OK

Generating XML reports...
Cloning into 'turbofan'...
Processing /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/turbofan
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Requirement already satisfied: numpy in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from turbofan==0.0.0.0) (1.22.3)
Requirement already satisfied: scipy in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from turbofan==0.0.0.0) (1.8.0)
Requirement already satisfied: pint in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from turbofan==0.0.0.0) (0.18)
Requirement already satisfied: future in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from turbofan==0.0.0.0) (0.18.2)
Requirement already satisfied: packaging in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pint->turbofan==0.0.0.0) (21.3)
Requirement already satisfied: pyparsing!=3.0.5,>=2.0.2 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from packaging->pint->turbofan==0.0.0.0) (3.0.7)
Building wheels for collected packages: turbofan
  Building wheel for turbofan (setup.py): started
  Building wheel for turbofan (setup.py): finished with status 'done'
  Created wheel for turbofan: filename=turbofan-0.0.0.0-py3-none-any.whl size=43849 sha256=c0ec5d3cbb44e504cc55da719e821288fe06416e738644c2684bbb422b7a7d42
  Stored in directory: /private/var/folders/qk/9zkf0syn149fvhw9mh7hgd5w0000gp/T/pip-ephem-wheel-cache-x7gt3yrn/wheels/67/9f/2a/23fd3cf94812328c052add0a8471008531d47a194b329785ae
Successfully built turbofan
Installing collected packages: turbofan
  Attempting uninstall: turbofan
    Found existing installation: turbofan 0.0.0.0
    Uninstalling turbofan-0.0.0.0:
      Successfully uninstalled turbofan-0.0.0.0
Successfully installed turbofan-0.0.0.0

Running tests...
----------------------------------------------------------------------
adding test for 'turbofan/engine_test.py'
.
----------------------------------------------------------------------
Ran 1 test in 0.001s

OK

Generating XML reports...
Cloning into 'solar'...
Requirement already satisfied: pandas in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (1.4.1)
Requirement already satisfied: numpy>=1.18.5 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pandas) (1.22.3)
Requirement already satisfied: python-dateutil>=2.8.1 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pandas) (2.8.2)
Requirement already satisfied: pytz>=2020.1 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pandas) (2022.1)
Requirement already satisfied: six>=1.5 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from python-dateutil>=2.8.1->pandas) (1.16.0)
Collecting git+https://github.com/convexengineering/gpfit.git
  Cloning https://github.com/convexengineering/gpfit.git to /private/var/folders/qk/9zkf0syn149fvhw9mh7hgd5w0000gp/T/pip-req-build-brd1d8m0
  Running command git clone --filter=blob:none --quiet https://github.com/convexengineering/gpfit.git /private/var/folders/qk/9zkf0syn149fvhw9mh7hgd5w0000gp/T/pip-req-build-brd1d8m0
  Resolved https://github.com/convexengineering/gpfit.git to commit 3c8025f12ba5360fdeb71c270e55d4c93e1676fd
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Requirement already satisfied: numpy in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpfit==0.2.0) (1.22.3)
Requirement already satisfied: scipy in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpfit==0.2.0) (1.8.0)
Requirement already satisfied: gpkit in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gpkit (from gpfit==0.2.0) (1.1.1)
Requirement already satisfied: matplotlib>=3.3.2 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpfit==0.2.0) (3.5.1)
Requirement already satisfied: pytest>=6.2.5 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpfit==0.2.0) (7.1.1)
Requirement already satisfied: pytest-mpl>=0.13 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpfit==0.2.0) (0.14.0)
Requirement already satisfied: pyparsing>=2.2.1 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit==0.2.0) (3.0.7)
Requirement already satisfied: python-dateutil>=2.7 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit==0.2.0) (2.8.2)
Requirement already satisfied: cycler>=0.10 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit==0.2.0) (0.11.0)
Requirement already satisfied: pillow>=6.2.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit==0.2.0) (9.0.1)
Requirement already satisfied: fonttools>=4.22.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit==0.2.0) (4.31.2)
Requirement already satisfied: kiwisolver>=1.0.1 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit==0.2.0) (1.4.2)
Requirement already satisfied: packaging>=20.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit==0.2.0) (21.3)
Requirement already satisfied: iniconfig in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest>=6.2.5->gpfit==0.2.0) (1.1.1)
Requirement already satisfied: tomli>=1.0.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest>=6.2.5->gpfit==0.2.0) (2.0.1)
Requirement already satisfied: pluggy<2.0,>=0.12 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest>=6.2.5->gpfit==0.2.0) (1.0.0)
Requirement already satisfied: py>=1.8.2 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest>=6.2.5->gpfit==0.2.0) (1.11.0)
Requirement already satisfied: attrs>=19.2.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest>=6.2.5->gpfit==0.2.0) (21.4.0)
Requirement already satisfied: Jinja2 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest-mpl>=0.13->gpfit==0.2.0) (3.1.1)
Requirement already satisfied: pint>=0.8.1 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkit->gpfit==0.2.0) (0.18)
Requirement already satisfied: plotly in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkit->gpfit==0.2.0) (5.6.0)
Requirement already satisfied: adce in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkit->gpfit==0.2.0) (1.3.3.2)
Requirement already satisfied: cvxopt>=1.1.8 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkit->gpfit==0.2.0) (1.3.0)
Requirement already satisfied: six>=1.5 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from python-dateutil>=2.7->matplotlib>=3.3.2->gpfit==0.2.0) (1.16.0)
Requirement already satisfied: MarkupSafe>=2.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from Jinja2->pytest-mpl>=0.13->gpfit==0.2.0) (2.1.1)
Requirement already satisfied: tenacity>=6.2.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from plotly->gpkit->gpfit==0.2.0) (8.0.1)
Collecting git+https://github.com/convexengineering/gassolar.git
  Cloning https://github.com/convexengineering/gassolar.git to /private/var/folders/qk/9zkf0syn149fvhw9mh7hgd5w0000gp/T/pip-req-build-vbtgqff3
  Running command git clone --filter=blob:none --quiet https://github.com/convexengineering/gassolar.git /private/var/folders/qk/9zkf0syn149fvhw9mh7hgd5w0000gp/T/pip-req-build-vbtgqff3
  Resolved https://github.com/convexengineering/gassolar.git to commit 90c91cc6b980b44bedaf87ad004654b67a11431c
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Requirement already satisfied: numpy in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gassolar==0.0.0.0) (1.22.3)
Requirement already satisfied: scipy in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gassolar==0.0.0.0) (1.8.0)
Requirement already satisfied: gpkit in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gpkit (from gassolar==0.0.0.0) (1.1.1)
Requirement already satisfied: pandas in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gassolar==0.0.0.0) (1.4.1)
Requirement already satisfied: gpfit in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gassolar==0.0.0.0) (0.2.0)
Requirement already satisfied: pytest>=6.2.5 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpfit->gassolar==0.0.0.0) (7.1.1)
Requirement already satisfied: pytest-mpl>=0.13 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpfit->gassolar==0.0.0.0) (0.14.0)
Requirement already satisfied: matplotlib>=3.3.2 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpfit->gassolar==0.0.0.0) (3.5.1)
Requirement already satisfied: pint>=0.8.1 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkit->gassolar==0.0.0.0) (0.18)
Requirement already satisfied: plotly in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkit->gassolar==0.0.0.0) (5.6.0)
Requirement already satisfied: adce in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkit->gassolar==0.0.0.0) (1.3.3.2)
Requirement already satisfied: cvxopt>=1.1.8 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkit->gassolar==0.0.0.0) (1.3.0)
Requirement already satisfied: pytz>=2020.1 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pandas->gassolar==0.0.0.0) (2022.1)
Requirement already satisfied: python-dateutil>=2.8.1 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pandas->gassolar==0.0.0.0) (2.8.2)
Requirement already satisfied: pyparsing>=2.2.1 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit->gassolar==0.0.0.0) (3.0.7)
Requirement already satisfied: packaging>=20.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit->gassolar==0.0.0.0) (21.3)
Requirement already satisfied: cycler>=0.10 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit->gassolar==0.0.0.0) (0.11.0)
Requirement already satisfied: pillow>=6.2.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit->gassolar==0.0.0.0) (9.0.1)
Requirement already satisfied: kiwisolver>=1.0.1 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit->gassolar==0.0.0.0) (1.4.2)
Requirement already satisfied: fonttools>=4.22.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit->gassolar==0.0.0.0) (4.31.2)
Requirement already satisfied: pluggy<2.0,>=0.12 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest>=6.2.5->gpfit->gassolar==0.0.0.0) (1.0.0)
Requirement already satisfied: iniconfig in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest>=6.2.5->gpfit->gassolar==0.0.0.0) (1.1.1)
Requirement already satisfied: attrs>=19.2.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest>=6.2.5->gpfit->gassolar==0.0.0.0) (21.4.0)
Requirement already satisfied: tomli>=1.0.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest>=6.2.5->gpfit->gassolar==0.0.0.0) (2.0.1)
Requirement already satisfied: py>=1.8.2 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest>=6.2.5->gpfit->gassolar==0.0.0.0) (1.11.0)
Requirement already satisfied: Jinja2 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest-mpl>=0.13->gpfit->gassolar==0.0.0.0) (3.1.1)
Requirement already satisfied: six>=1.5 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from python-dateutil>=2.8.1->pandas->gassolar==0.0.0.0) (1.16.0)
Requirement already satisfied: tenacity>=6.2.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from plotly->gpkit->gassolar==0.0.0.0) (8.0.1)
Requirement already satisfied: MarkupSafe>=2.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from Jinja2->pytest-mpl>=0.13->gpfit->gassolar==0.0.0.0) (2.1.1)
Processing /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/solar
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Requirement already satisfied: numpy in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from solar==0.0.0.0) (1.22.3)
Requirement already satisfied: scipy in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from solar==0.0.0.0) (1.8.0)
Requirement already satisfied: gpkit in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gpkit (from solar==0.0.0.0) (1.1.1)
Requirement already satisfied: pandas in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from solar==0.0.0.0) (1.4.1)
Requirement already satisfied: gpfit in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from solar==0.0.0.0) (0.2.0)
Requirement already satisfied: gpkitmodels in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt (from solar==0.0.0.0) (0.0.0.0)
Requirement already satisfied: matplotlib>=3.3.2 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpfit->solar==0.0.0.0) (3.5.1)
Requirement already satisfied: pytest-mpl>=0.13 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpfit->solar==0.0.0.0) (0.14.0)
Requirement already satisfied: pytest>=6.2.5 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpfit->solar==0.0.0.0) (7.1.1)
Requirement already satisfied: pint>=0.8.1 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkit->solar==0.0.0.0) (0.18)
Requirement already satisfied: plotly in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkit->solar==0.0.0.0) (5.6.0)
Requirement already satisfied: adce in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkit->solar==0.0.0.0) (1.3.3.2)
Requirement already satisfied: cvxopt>=1.1.8 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkit->solar==0.0.0.0) (1.3.0)
Requirement already satisfied: future in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkitmodels->solar==0.0.0.0) (0.18.2)
Requirement already satisfied: python-dateutil>=2.8.1 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pandas->solar==0.0.0.0) (2.8.2)
Requirement already satisfied: pytz>=2020.1 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pandas->solar==0.0.0.0) (2022.1)
Requirement already satisfied: kiwisolver>=1.0.1 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit->solar==0.0.0.0) (1.4.2)
Requirement already satisfied: packaging>=20.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit->solar==0.0.0.0) (21.3)
Requirement already satisfied: pillow>=6.2.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit->solar==0.0.0.0) (9.0.1)
Requirement already satisfied: cycler>=0.10 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit->solar==0.0.0.0) (0.11.0)
Requirement already satisfied: pyparsing>=2.2.1 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit->solar==0.0.0.0) (3.0.7)
Requirement already satisfied: fonttools>=4.22.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit->solar==0.0.0.0) (4.31.2)
Requirement already satisfied: pluggy<2.0,>=0.12 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest>=6.2.5->gpfit->solar==0.0.0.0) (1.0.0)
Requirement already satisfied: py>=1.8.2 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest>=6.2.5->gpfit->solar==0.0.0.0) (1.11.0)
Requirement already satisfied: attrs>=19.2.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest>=6.2.5->gpfit->solar==0.0.0.0) (21.4.0)
Requirement already satisfied: iniconfig in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest>=6.2.5->gpfit->solar==0.0.0.0) (1.1.1)
Requirement already satisfied: tomli>=1.0.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest>=6.2.5->gpfit->solar==0.0.0.0) (2.0.1)
Requirement already satisfied: Jinja2 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest-mpl>=0.13->gpfit->solar==0.0.0.0) (3.1.1)
Requirement already satisfied: six>=1.5 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from python-dateutil>=2.8.1->pandas->solar==0.0.0.0) (1.16.0)
Requirement already satisfied: tenacity>=6.2.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from plotly->gpkit->solar==0.0.0.0) (8.0.1)
Requirement already satisfied: MarkupSafe>=2.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from Jinja2->pytest-mpl>=0.13->gpfit->solar==0.0.0.0) (2.1.1)
Building wheels for collected packages: solar
  Building wheel for solar (setup.py): started
  Building wheel for solar (setup.py): finished with status 'done'
  Created wheel for solar: filename=solar-0.0.0.0-py3-none-any.whl size=14861 sha256=c32fded06d0a0fadf4af7d3bad320251a4142388d321c0cf4916e92d4c7bda0d
  Stored in directory: /private/var/folders/qk/9zkf0syn149fvhw9mh7hgd5w0000gp/T/pip-ephem-wheel-cache-yste122w/wheels/f3/3d/a7/eb55f8a522cc5ecb99a84fca0a90a8dda658b5a05c1f871a8a
Successfully built solar
Installing collected packages: solar
Successfully installed solar-0.0.0.0

Running tests...
----------------------------------------------------------------------
adding test for 'solar/sens_chart.py'
adding test for 'solar/season.py'
adding test for 'solar/npod_trade.py'
.
----------------------------------------------------------------------
Ran 1 test in 0.001s

OK

Generating XML reports...
Cloning into 'gplibrary'...
Requirement already satisfied: pandas in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (1.4.1)
Requirement already satisfied: pytz>=2020.1 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pandas) (2022.1)
Requirement already satisfied: python-dateutil>=2.8.1 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pandas) (2.8.2)
Requirement already satisfied: numpy>=1.18.5 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pandas) (1.22.3)
Requirement already satisfied: six>=1.5 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from python-dateutil>=2.8.1->pandas) (1.16.0)
Collecting git+https://github.com/hoburg/gpfit.git
  Cloning https://github.com/hoburg/gpfit.git to /private/var/folders/qk/9zkf0syn149fvhw9mh7hgd5w0000gp/T/pip-req-build-pw1o79w9
  Running command git clone --filter=blob:none --quiet https://github.com/hoburg/gpfit.git /private/var/folders/qk/9zkf0syn149fvhw9mh7hgd5w0000gp/T/pip-req-build-pw1o79w9
  Resolved https://github.com/hoburg/gpfit.git to commit 3c8025f12ba5360fdeb71c270e55d4c93e1676fd
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Requirement already satisfied: numpy in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpfit==0.2.0) (1.22.3)
Requirement already satisfied: scipy in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpfit==0.2.0) (1.8.0)
Requirement already satisfied: gpkit in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gpkit (from gpfit==0.2.0) (1.1.1)
Requirement already satisfied: matplotlib>=3.3.2 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpfit==0.2.0) (3.5.1)
Requirement already satisfied: pytest>=6.2.5 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpfit==0.2.0) (7.1.1)
Requirement already satisfied: pytest-mpl>=0.13 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpfit==0.2.0) (0.14.0)
Requirement already satisfied: cycler>=0.10 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit==0.2.0) (0.11.0)
Requirement already satisfied: kiwisolver>=1.0.1 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit==0.2.0) (1.4.2)
Requirement already satisfied: fonttools>=4.22.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit==0.2.0) (4.31.2)
Requirement already satisfied: pillow>=6.2.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit==0.2.0) (9.0.1)
Requirement already satisfied: python-dateutil>=2.7 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit==0.2.0) (2.8.2)
Requirement already satisfied: pyparsing>=2.2.1 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit==0.2.0) (3.0.7)
Requirement already satisfied: packaging>=20.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from matplotlib>=3.3.2->gpfit==0.2.0) (21.3)
Requirement already satisfied: pluggy<2.0,>=0.12 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest>=6.2.5->gpfit==0.2.0) (1.0.0)
Requirement already satisfied: attrs>=19.2.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest>=6.2.5->gpfit==0.2.0) (21.4.0)
Requirement already satisfied: tomli>=1.0.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest>=6.2.5->gpfit==0.2.0) (2.0.1)
Requirement already satisfied: iniconfig in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest>=6.2.5->gpfit==0.2.0) (1.1.1)
Requirement already satisfied: py>=1.8.2 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest>=6.2.5->gpfit==0.2.0) (1.11.0)
Requirement already satisfied: Jinja2 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pytest-mpl>=0.13->gpfit==0.2.0) (3.1.1)
Requirement already satisfied: pint>=0.8.1 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkit->gpfit==0.2.0) (0.18)
Requirement already satisfied: plotly in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkit->gpfit==0.2.0) (5.6.0)
Requirement already satisfied: adce in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkit->gpfit==0.2.0) (1.3.3.2)
Requirement already satisfied: cvxopt>=1.1.8 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkit->gpfit==0.2.0) (1.3.0)
Requirement already satisfied: six>=1.5 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from python-dateutil>=2.7->matplotlib>=3.3.2->gpfit==0.2.0) (1.16.0)
Requirement already satisfied: MarkupSafe>=2.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from Jinja2->pytest-mpl>=0.13->gpfit==0.2.0) (2.1.1)
Requirement already satisfied: tenacity>=6.2.0 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from plotly->gpkit->gpfit==0.2.0) (8.0.1)
Processing /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gplibrary
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Requirement already satisfied: numpy>=1.12 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkitmodels==0.0.0.0) (1.22.3)
Requirement already satisfied: scipy in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkitmodels==0.0.0.0) (1.8.0)
Requirement already satisfied: pint in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkitmodels==0.0.0.0) (0.18)
Requirement already satisfied: future in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from gpkitmodels==0.0.0.0) (0.18.2)
Requirement already satisfied: packaging in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from pint->gpkitmodels==0.0.0.0) (21.3)
Requirement already satisfied: pyparsing!=3.0.5,>=2.0.2 in /Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages (from packaging->pint->gpkitmodels==0.0.0.0) (3.0.7)
Building wheels for collected packages: gpkitmodels
  Building wheel for gpkitmodels (setup.py): started
  Building wheel for gpkitmodels (setup.py): finished with status 'done'
  Created wheel for gpkitmodels: filename=gpkitmodels-0.0.0.0-py3-none-any.whl size=66171 sha256=585aaca5be604c0a688e7fe989013a9e0f4775d575ae58642a43ca473015f03b
  Stored in directory: /private/var/folders/qk/9zkf0syn149fvhw9mh7hgd5w0000gp/T/pip-ephem-wheel-cache-zgy5fqn7/wheels/5f/1e/c4/c63683b98e237edca47d5fd549abe91e8f2b69de61342b5e65
Successfully built gpkitmodels
Installing collected packages: gpkitmodels
  Attempting uninstall: gpkitmodels
    Found existing installation: gpkitmodels 0.0.0.0
    Uninstalling gpkitmodels-0.0.0.0:
      Successfully uninstalled gpkitmodels-0.0.0.0
Successfully installed gpkitmodels-0.0.0.0

Running tests...
----------------------------------------------------------------------
adding test for 'gpkitmodels/GP/aircraft/wing/wing_test.py'
adding test for 'gpkitmodels/GP/aircraft/tail/tail_tests.py'
adding test for 'gpkitmodels/GP/aircraft/fuselage/test_fuselage.py'
adding test for 'gpkitmodels/GP/aircraft/prop/prop_test.py'
adding test for 'gpkitmodels/GP/aircraft/motor/motor_test.py'
adding test for 'gpkitmodels/SP/SimPleAC/SimPleAC.py'
adding test for 'gpkitmodels/SP/SimPleAC/SimPleAC_mission.py'
adding test for 'gpkitmodels/SP/SimPleAC/SimPleAC_multimission.py'
EEEEE/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gpkit/gpkit/constraints/sgp.py:177: UserWarning: SGP not convergent: Cost rose by 6.1% (1588.62 to 1685.18) on GP solve 2. Details can be found in `m.program.results` or by solving at a higher verbosity. Note convergence is not guaranteed for models with SignomialEqualities.
  pywarnings.warn(
...Starting a sequence of GP solves
 for 4 free variables
  in 1 locally-GP constraints
  and for 21 free variables
       in 22 posynomial inequalities.

GP Solve 1
Using solver 'cvxopt'
 for 21 free variables
  in 22 posynomial inequalities.
Solving took 0.0145 seconds.
Solved cost was 5717.

GP Solve 2
Using solver 'cvxopt'
 for 21 free variables
  in 22 posynomial inequalities.
Solving took 0.0152 seconds.
Solved cost was 4538.

GP Solve 3
Using solver 'cvxopt'
 for 21 free variables
  in 22 posynomial inequalities.
Solving took 0.0184 seconds.
Solved cost was 4536.

GP Solve 4
Using solver 'cvxopt'
 for 21 free variables
  in 22 posynomial inequalities.
Solving took 0.0183 seconds.
Solved cost was 4536.

Solving took 0.0693 seconds and 4 GP solves.

======================================================================
ERROR [0.020s]: test_gpkitmodels_GP_aircraft_fuselage_test_fuselage_py_cvxopt (gpkit.tests.from_paths.TestFiles)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gpkit/gpkit/tests/helpers.py", line 55, in test
    testfn(name, import_dict, path)(self)
  File "/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gpkit/gpkit/tests/from_paths.py", line 48, in <lambda>
    lambda self: getattr(self, name)()))  # pylint:disable=undefined-variable
  File "/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gpkit/gpkit/tests/from_paths.py", line 34, in test_fn
    mod = __import__(os.path.basename(path)[:-3])
  File "/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gplibrary/gpkitmodels/GP/aircraft/fuselage/test_fuselage.py", line 3, in <module>
    from gpkitmodels.GP.aircraft.wing.wing_test import FlightState
  File "/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages/gpkitmodels/GP/aircraft/wing/wing_test.py", line 2, in <module>
    from gpkitmodels.GP.aircraft.wing.wing import Wing
  File "/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages/gpkitmodels/GP/aircraft/wing/wing.py", line 10, in <module>
    from .capspar import CapSpar
  File "/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages/gpkitmodels/GP/aircraft/wing/capspar.py", line 4, in <module>
    from .gustloading import GustL
  File "/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages/gpkitmodels/GP/aircraft/wing/gustloading.py", line 4, in <module>
    from ad.admath import cos
ModuleNotFoundError: No module named 'ad'

======================================================================
ERROR [0.554s]: test_gpkitmodels_GP_aircraft_motor_motor_test_py_cvxopt (gpkit.tests.from_paths.TestFiles)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gpkit/gpkit/tests/helpers.py", line 55, in test
    testfn(name, import_dict, path)(self)
  File "/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gpkit/gpkit/tests/from_paths.py", line 48, in <lambda>
    lambda self: getattr(self, name)()))  # pylint:disable=undefined-variable
  File "/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gpkit/gpkit/tests/from_paths.py", line 34, in test_fn
    mod = __import__(os.path.basename(path)[:-3])
  File "/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gplibrary/gpkitmodels/GP/aircraft/motor/motor_test.py", line 2, in <module>
    from gpkitmodels.GP.aircraft.motor.motor import Propulsor, Motor, MotorPerf
  File "/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages/gpkitmodels/GP/aircraft/motor/motor.py", line 4, in <module>
    from gpkitmodels.GP.aircraft.prop.propeller import Propeller, ActuatorProp
  File "/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages/gpkitmodels/GP/aircraft/prop/propeller.py", line 5, in <module>
    from gpfit.fit_constraintset import XfoilFit
ModuleNotFoundError: No module named 'gpfit.fit_constraintset'

======================================================================
ERROR [0.003s]: test_gpkitmodels_GP_aircraft_prop_prop_test_py_cvxopt (gpkit.tests.from_paths.TestFiles)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gpkit/gpkit/tests/helpers.py", line 55, in test
    testfn(name, import_dict, path)(self)
  File "/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gpkit/gpkit/tests/from_paths.py", line 48, in <lambda>
    lambda self: getattr(self, name)()))  # pylint:disable=undefined-variable
  File "/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gpkit/gpkit/tests/from_paths.py", line 34, in test_fn
    mod = __import__(os.path.basename(path)[:-3])
  File "/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gplibrary/gpkitmodels/GP/aircraft/prop/prop_test.py", line 2, in <module>
    from gpkitmodels.GP.aircraft.prop.propeller import Propeller, ActuatorProp
  File "/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages/gpkitmodels/GP/aircraft/prop/propeller.py", line 5, in <module>
    from gpfit.fit_constraintset import XfoilFit
ModuleNotFoundError: No module named 'gpfit.fit_constraintset'

======================================================================
ERROR [0.004s]: test_gpkitmodels_GP_aircraft_tail_tail_tests_py_cvxopt (gpkit.tests.from_paths.TestFiles)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gpkit/gpkit/tests/helpers.py", line 55, in test
    testfn(name, import_dict, path)(self)
  File "/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gpkit/gpkit/tests/from_paths.py", line 48, in <lambda>
    lambda self: getattr(self, name)()))  # pylint:disable=undefined-variable
  File "/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gpkit/gpkit/tests/from_paths.py", line 34, in test_fn
    mod = __import__(os.path.basename(path)[:-3])
  File "/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gplibrary/gpkitmodels/GP/aircraft/tail/tail_tests.py", line 2, in <module>
    from gpkitmodels.GP.aircraft.tail.horizontal_tail import HorizontalTail
  File "/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages/gpkitmodels/GP/aircraft/tail/horizontal_tail.py", line 4, in <module>
    from .tail_aero import TailAero
  File "/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages/gpkitmodels/GP/aircraft/tail/tail_aero.py", line 5, in <module>
    from gpfit.fit_constraintset import XfoilFit
ModuleNotFoundError: No module named 'gpfit.fit_constraintset'

======================================================================
ERROR [0.003s]: test_gpkitmodels_GP_aircraft_wing_wing_test_py_cvxopt (gpkit.tests.from_paths.TestFiles)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gpkit/gpkit/tests/helpers.py", line 55, in test
    testfn(name, import_dict, path)(self)
  File "/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gpkit/gpkit/tests/from_paths.py", line 48, in <lambda>
    lambda self: getattr(self, name)()))  # pylint:disable=undefined-variable
  File "/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gpkit/gpkit/tests/from_paths.py", line 34, in test_fn
    mod = __import__(os.path.basename(path)[:-3])
  File "/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/gplibrary/gpkitmodels/GP/aircraft/wing/wing_test.py", line 2, in <module>
    from gpkitmodels.GP.aircraft.wing.wing import Wing
  File "/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages/gpkitmodels/GP/aircraft/wing/wing.py", line 10, in <module>
    from .capspar import CapSpar
  File "/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages/gpkitmodels/GP/aircraft/wing/capspar.py", line 4, in <module>
    from .gustloading import GustL
  File "/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/lib/python3.9/site-packages/gpkitmodels/GP/aircraft/wing/gustloading.py", line 4, in <module>
    from ad.admath import cos
ModuleNotFoundError: No module named 'ad'

----------------------------------------------------------------------
Ran 8 tests in 2.031s

FAILED (errors=5)

Generating XML reports...
Cloning into 'eVTOL'...

Running tests...
----------------------------------------------------------------------
adding test for 'models/model_tests.py'
.
----------------------------------------------------------------------
Ran 1 test in 0.001s

OK

Generating XML reports...
USING LOCAL DIRECTORY AS GPKITMODELS DIRECTORY
calling ['python', '/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/bin/pip', 'install', '--no-cache-dir', '--no-deps', '-e', '.']
  attempt 1
calling ['git', 'clone', '--depth', '1', '-b', 'master', 'https://github.com/convexengineering/SPaircraft.git']
  attempt 1

SETTINGS
defaultdict(<class 'str'>, {'skipsolvers': 'cvxopt', 'pip install': 'git+https://github.com/hoburg/turbofan.git', 'gpkit-models branch': 'master'})

calling ['python', '/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/bin/pip', 'install', 'git+https://github.com/hoburg/turbofan.git']
  attempt 1
calling ['python', '/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/bin/pip', 'install', '.']
  attempt 1
calling ['git', 'clone', '--depth', '1', '-b', 'master', 'https://github.com/convexengineering/robust.git']
  attempt 1

SETTINGS
defaultdict(<class 'str'>, {})

calling ['python', '/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/bin/pip', 'install', '.']
  attempt 1
  attempt 2
  attempt 3
  attempt 4
  attempt 5
calling ['git', 'clone', '--depth', '1', '-b', 'master', 'https://github.com/convexengineering/shopping.git']
  attempt 1

SETTINGS
defaultdict(<class 'str'>, {})

calling ['git', 'clone', '--depth', '1', '-b', 'master', 'https://github.com/convexengineering/gassolar.git']
  attempt 1

SETTINGS
defaultdict(<class 'str'>, {'pip install': 'pandas, git+https://github.com/hoburg/gpfit.git', 'gpkit-models branch': 'master', 'skipsolvers': 'cvxopt'})

calling ['python', '/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/bin/pip', 'install', 'pandas']
  attempt 1
calling ['python', '/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/bin/pip', 'install', 'git+https://github.com/hoburg/gpfit.git']
  attempt 1
calling ['python', '/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/bin/pip', 'install', '.']
  attempt 1
calling ['git', 'clone', '--depth', '1', '-b', 'master', 'https://github.com/convexengineering/jho.git']
  attempt 1

SETTINGS
defaultdict(<class 'str'>, {'pip install': 'pandas, git+https://github.com/hoburg/gpfit.git', 'gpkit-models branch': 'master', 'skipsolvers': 'cvxopt'})

calling ['python', '/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/bin/pip', 'install', 'pandas']
  attempt 1
calling ['python', '/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/bin/pip', 'install', 'git+https://github.com/hoburg/gpfit.git']
  attempt 1
calling ['git', 'clone', '--depth', '1', '-b', 'master', 'https://github.com/convexengineering/turbofan.git']
  attempt 1

SETTINGS
defaultdict(<class 'str'>, {'skipsolvers': 'cvxopt, mosek_cli', 'gpkit-models branch': 'master'})

calling ['python', '/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/bin/pip', 'install', '.']
  attempt 1
calling ['git', 'clone', '--depth', '1', '-b', 'master', 'https://github.com/convexengineering/solar.git']
  attempt 1

SETTINGS
defaultdict(<class 'str'>, {'pip install': 'pandas, git+https://github.com/convexengineering/gpfit.git, git+https://github.com/convexengineering/gassolar.git', 'gpkit-models branch': 'master', 'skipsolvers': 'cvxopt'})

calling ['python', '/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/bin/pip', 'install', 'pandas']
  attempt 1
calling ['python', '/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/bin/pip', 'install', 'git+https://github.com/convexengineering/gpfit.git']
  attempt 1
calling ['python', '/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/bin/pip', 'install', 'git+https://github.com/convexengineering/gassolar.git']
  attempt 1
calling ['python', '/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/bin/pip', 'install', '.']
  attempt 1
calling ['git', 'clone', '--depth', '1', '-b', 'master', 'https://github.com/convexengineering/gplibrary.git']
  attempt 1

SETTINGS
defaultdict(<class 'str'>, {'pip install': 'pandas, git+https://github.com/hoburg/gpfit.git'})

calling ['python', '/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/bin/pip', 'install', 'pandas']
  attempt 1
calling ['python', '/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/bin/pip', 'install', 'git+https://github.com/hoburg/gpfit.git']
  attempt 1
calling ['python', '/Users/jenkins/workspace/CE_gplibrary_Push_research_models/cvxopt/venv_jenkins/bin/pip', 'install', '.']
  attempt 1
calling ['git', 'clone', '--depth', '1', '-b', 'master', 'https://github.com/convexengineering/eVTOL.git']
  attempt 1

SETTINGS
defaultdict(<class 'str'>, {'skipsolvers': 'cvxopt'})

[Execution node] check if [macys_VM] is in [[windows10x64]]
Run condition [Execution node ] preventing perform for step [Execute Windows batch command]
Build step 'Console output (build log) parsing' changed build result to FAILURE
Recording test results
[Checks API] No suitable checks publisher found.
[WS-CLEANUP] Deleting project workspace...
[WS-CLEANUP] Deferred wipeout is used...
[WS-CLEANUP] done
Finished: FAILURE