Console Output

Started by upstream project "TransportMaps-testpypi-mpi" build number 92
originally caused by:
 [URLTrigger] A change within the response URL invocation (log)
Running as SYSTEM
[EnvInject] - Loading node environment variables.
Building remotely on reynolds in workspace /jenkins/workspace/TransportMaps-testpypi-mpi/COMPILER/gcc/MACHINE/reynolds/PYTHON_EXE/python2/VENV_SYS/virtualenv
[WS-CLEANUP] Deleting project workspace...
[WS-CLEANUP] Deferred wipeout is used...
[GitCheckoutListener] SCM 'hudson.scm.NullSCM' is not of type GitSCM
[virtualenv] $ /bin/bash /tmp/jenkins12230909389302299995.sh
created virtual environment CPython2.7.18.final.0-64 in 115ms
  creator CPython2Posix(dest=/jenkins/workspace/TransportMaps-testpypi-mpi/COMPILER/gcc/MACHINE/reynolds/PYTHON_EXE/python2/VENV_SYS/virtualenv/venv_TransportMaps-testpypi-mpi_python2, clear=False, global=False)
  seeder FromAppData(download=False, pip=latest, setuptools=latest, wheel=latest, pkg_resources=latest, via=copy, app_data_dir=/home/jenkins/.local/share/virtualenv/seed-app-data/v1.0.1.debian.1)
  activators BashActivator,CShellActivator,FishActivator,PowerShellActivator,PythonActivator
Python 2.7.18

TEST_NAME: TransportMaps-testpypi-mpi
HOSTNAME: reynolds
PATH: /jenkins/workspace/TransportMaps-testpypi-mpi/COMPILER/gcc/MACHINE/reynolds/PYTHON_EXE/python2/VENV_SYS/virtualenv/venv_TransportMaps-testpypi-mpi_python2/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin:/home/jenkins/bin
VENV_OPTS: 
PATH: /jenkins/workspace/TransportMaps-testpypi-mpi/COMPILER/gcc/MACHINE/reynolds/PYTHON_EXE/python2/VENV_SYS/virtualenv/venv_TransportMaps-testpypi-mpi_python2/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin:/home/jenkins/bin
PY-VERS: 
PY-CMD: import logging;import TransportMaps as TM;import warnings;warnings.simplefilter('ignore');TM.tests.run_all(logging.ERROR,ttype='parallel')

Upgrading pip
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
Collecting pip
  Using cached pip-20.3.4-py2.py3-none-any.whl (1.5 MB)
Installing collected packages: pip
  Attempting uninstall: pip
    Found existing installation: pip 20.0.2
    Uninstalling pip-20.0.2:
      Successfully uninstalled pip-20.0.2
Successfully installed pip-20.3.4
Installing numpy
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support pip 21.0 will remove support for this functionality.
Collecting numpy
  Using cached numpy-1.16.6-cp27-cp27mu-manylinux1_x86_64.whl (17.0 MB)
Installing collected packages: numpy
Successfully installed numpy-1.16.6
Checking out requirements files
Installing requirements
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support pip 21.0 will remove support for this functionality.
Requirement already satisfied: numpy>=1.14 in /jenkins/workspace/TransportMaps-testpypi-mpi/COMPILER/gcc/MACHINE/reynolds/PYTHON_EXE/python2/VENV_SYS/virtualenv/venv_TransportMaps-testpypi-mpi_python2/lib/python2.7/site-packages (from -r requirements.txt (line 1)) (1.16.6)
Processing /home/jenkins/.cache/pip/wheels/08/d1/78/bb76eed0589a31eaf4d7f62b3a53ab79c6d4619d99dcf96c0b/orthpol_light-1.0.1-cp27-cp27mu-linux_x86_64.whl
Collecting scipy
  Using cached scipy-1.2.3-cp27-cp27mu-manylinux1_x86_64.whl (24.8 MB)
Processing /home/jenkins/.cache/pip/wheels/c8/6c/62/1a4aa12e4622f93d036dc48051256c84838bcf5c56557e68e9/SpectralToolbox-1.0.12-cp27-cp27mu-linux_x86_64.whl
Collecting dill
  Using cached dill-0.3.4-py2.py3-none-any.whl (86 kB)
Processing /home/jenkins/.cache/pip/wheels/e2/9a/ab/067414de0670f95436345d4ef33337d511a47aabc6c3307062/scikit_sparse-0.4.4-cp27-cp27mu-linux_x86_64.whl
Installing collected packages: orthpol-light, scipy, SpectralToolbox, dill, scikit-sparse
Successfully installed SpectralToolbox-1.0.12 dill-0.3.4 orthpol-light-1.0.1 scikit-sparse-0.4.4 scipy-1.2.3
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support pip 21.0 will remove support for this functionality.
Processing /home/jenkins/.cache/pip/wheels/e6/fc/99/e2f1c83800e46f8530439054fd670d427315ea91868d1df912/mpi4py-3.1.1-cp27-cp27mu-linux_x86_64.whl
Collecting h5py
  Using cached h5py-2.10.0-cp27-cp27mu-manylinux1_x86_64.whl (2.8 MB)
Requirement already satisfied: numpy>=1.7 in /jenkins/workspace/TransportMaps-testpypi-mpi/COMPILER/gcc/MACHINE/reynolds/PYTHON_EXE/python2/VENV_SYS/virtualenv/venv_TransportMaps-testpypi-mpi_python2/lib/python2.7/site-packages (from h5py->-r requirements-H5PY.txt (line 2)) (1.16.6)
Collecting six
  Using cached six-1.16.0-py2.py3-none-any.whl (11 kB)
Installing collected packages: mpi4py, six, h5py
Successfully installed h5py-2.10.0 mpi4py-3.1.1 six-1.16.0
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support pip 21.0 will remove support for this functionality.
Requirement already satisfied: mpi4py in /jenkins/workspace/TransportMaps-testpypi-mpi/COMPILER/gcc/MACHINE/reynolds/PYTHON_EXE/python2/VENV_SYS/virtualenv/venv_TransportMaps-testpypi-mpi_python2/lib/python2.7/site-packages (from -r requirements-MPI.txt (line 1)) (3.1.1)
Processing /home/jenkins/.cache/pip/wheels/a0/b4/4b/102503a00d38141a903b02356ebe19339881d44b8b3dfecd8a/mpi_map-2.6-cp27-none-any.whl
Requirement already satisfied: dill in /jenkins/workspace/TransportMaps-testpypi-mpi/COMPILER/gcc/MACHINE/reynolds/PYTHON_EXE/python2/VENV_SYS/virtualenv/venv_TransportMaps-testpypi-mpi_python2/lib/python2.7/site-packages (from mpi_map>=2.0->-r requirements-MPI.txt (line 2)) (0.3.4)
Installing collected packages: mpi-map
Successfully installed mpi-map-2.6
Installing TransportMaps
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support pip 21.0 will remove support for this functionality.
Looking in indexes: https://testpypi.python.org/pypi
Processing /home/jenkins/.cache/pip/wheels/e9/be/25/fa30a9c6f9f0ca9d7780a52f97227579301e3377cce0a81c0e/TransportMaps-1.1b0-cp27-none-any.whl
Requirement already satisfied: h5py in /jenkins/workspace/TransportMaps-testpypi-mpi/COMPILER/gcc/MACHINE/reynolds/PYTHON_EXE/python2/VENV_SYS/virtualenv/venv_TransportMaps-testpypi-mpi_python2/lib/python2.7/site-packages (from TransportMaps) (2.10.0)
Requirement already satisfied: scipy in /jenkins/workspace/TransportMaps-testpypi-mpi/COMPILER/gcc/MACHINE/reynolds/PYTHON_EXE/python2/VENV_SYS/virtualenv/venv_TransportMaps-testpypi-mpi_python2/lib/python2.7/site-packages (from TransportMaps) (1.2.3)
Requirement already satisfied: SpectralToolbox>=1.0.7 in /jenkins/workspace/TransportMaps-testpypi-mpi/COMPILER/gcc/MACHINE/reynolds/PYTHON_EXE/python2/VENV_SYS/virtualenv/venv_TransportMaps-testpypi-mpi_python2/lib/python2.7/site-packages (from TransportMaps) (1.0.12)
Requirement already satisfied: dill in /jenkins/workspace/TransportMaps-testpypi-mpi/COMPILER/gcc/MACHINE/reynolds/PYTHON_EXE/python2/VENV_SYS/virtualenv/venv_TransportMaps-testpypi-mpi_python2/lib/python2.7/site-packages (from TransportMaps) (0.3.4)
Requirement already satisfied: numpy in /jenkins/workspace/TransportMaps-testpypi-mpi/COMPILER/gcc/MACHINE/reynolds/PYTHON_EXE/python2/VENV_SYS/virtualenv/venv_TransportMaps-testpypi-mpi_python2/lib/python2.7/site-packages (from TransportMaps) (1.16.6)
Requirement already satisfied: orthpol-light>=1.0.1 in /jenkins/workspace/TransportMaps-testpypi-mpi/COMPILER/gcc/MACHINE/reynolds/PYTHON_EXE/python2/VENV_SYS/virtualenv/venv_TransportMaps-testpypi-mpi_python2/lib/python2.7/site-packages (from TransportMaps) (1.0.1)
Requirement already satisfied: mpi4py in /jenkins/workspace/TransportMaps-testpypi-mpi/COMPILER/gcc/MACHINE/reynolds/PYTHON_EXE/python2/VENV_SYS/virtualenv/venv_TransportMaps-testpypi-mpi_python2/lib/python2.7/site-packages (from TransportMaps) (3.1.1)
Requirement already satisfied: six in /jenkins/workspace/TransportMaps-testpypi-mpi/COMPILER/gcc/MACHINE/reynolds/PYTHON_EXE/python2/VENV_SYS/virtualenv/venv_TransportMaps-testpypi-mpi_python2/lib/python2.7/site-packages (from h5py->TransportMaps) (1.16.0)
Installing collected packages: TransportMaps
Successfully installed TransportMaps-1.1b0
/jenkins/workspace/TransportMaps-testpypi-mpi/COMPILER/gcc/MACHINE/reynolds/PYTHON_EXE/python2/VENV_SYS/virtualenv
Running tests
/jenkins/workspace/TransportMaps-testpypi-mpi/COMPILER/gcc/MACHINE/reynolds/PYTHON_EXE/python2/VENV_SYS/virtualenv/venv_TransportMaps-testpypi-mpi_python2/lib/python2.7/site-packages/TransportMaps/External.py:35: UserWarning: MPI support disabled: install mpi4py and mpi_map if needed.
  warnings.warn("MPI support disabled: install mpi4py and mpi_map if needed.")
/jenkins/workspace/TransportMaps-testpypi-mpi/COMPILER/gcc/MACHINE/reynolds/PYTHON_EXE/python2/VENV_SYS/virtualenv/venv_TransportMaps-testpypi-mpi_python2/lib/python2.7/site-packages/TransportMaps/External.py:46: UserWarning: Plotting support disabled: install matplotlib if needed.
  warnings.warn("Plotting support disabled: install matplotlib if needed.")
/jenkins/workspace/TransportMaps-testpypi-mpi/COMPILER/gcc/MACHINE/reynolds/PYTHON_EXE/python2/VENV_SYS/virtualenv/venv_TransportMaps-testpypi-mpi_python2/lib/python2.7/site-packages/TransportMaps/External.py:63: UserWarning: pyhmc is not supported: install pyhmc if needed.
  warnings.warn("pyhmc is not supported: install pyhmc if needed.")
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/jenkins/workspace/TransportMaps-testpypi-mpi/COMPILER/gcc/MACHINE/reynolds/PYTHON_EXE/python2/VENV_SYS/virtualenv/venv_TransportMaps-testpypi-mpi_python2/lib/python2.7/site-packages/TransportMaps/__init__.py", line 45, in <module>
    from . import Distributions
  File "/jenkins/workspace/TransportMaps-testpypi-mpi/COMPILER/gcc/MACHINE/reynolds/PYTHON_EXE/python2/VENV_SYS/virtualenv/venv_TransportMaps-testpypi-mpi_python2/lib/python2.7/site-packages/TransportMaps/Distributions/__init__.py", line 29, in <module>
    from . import FrozenDistributions
  File "/jenkins/workspace/TransportMaps-testpypi-mpi/COMPILER/gcc/MACHINE/reynolds/PYTHON_EXE/python2/VENV_SYS/virtualenv/venv_TransportMaps-testpypi-mpi_python2/lib/python2.7/site-packages/TransportMaps/Distributions/FrozenDistributions.py", line 33, in <module>
    import SpectralToolbox.Spectral1D as S1D
  File "/jenkins/workspace/TransportMaps-testpypi-mpi/COMPILER/gcc/MACHINE/reynolds/PYTHON_EXE/python2/VENV_SYS/virtualenv/venv_TransportMaps-testpypi-mpi_python2/lib/python2.7/site-packages/SpectralToolbox/__init__.py", line 33, in <module>
    import SpectralToolbox.tests
  File "/jenkins/workspace/TransportMaps-testpypi-mpi/COMPILER/gcc/MACHINE/reynolds/PYTHON_EXE/python2/VENV_SYS/virtualenv/venv_TransportMaps-testpypi-mpi_python2/lib/python2.7/site-packages/SpectralToolbox/tests/__init__.py", line 31, in <module>
    from SpectralToolbox.tests.test_all import *
  File "/jenkins/workspace/TransportMaps-testpypi-mpi/COMPILER/gcc/MACHINE/reynolds/PYTHON_EXE/python2/VENV_SYS/virtualenv/venv_TransportMaps-testpypi-mpi_python2/lib/python2.7/site-packages/SpectralToolbox/tests/test_all.py", line 33, in <module>
    from SpectralToolbox.tests import test_spectral1d
  File "/jenkins/workspace/TransportMaps-testpypi-mpi/COMPILER/gcc/MACHINE/reynolds/PYTHON_EXE/python2/VENV_SYS/virtualenv/venv_TransportMaps-testpypi-mpi_python2/lib/python2.7/site-packages/SpectralToolbox/tests/test_spectral1d.py", line 38, in <module>
    import SpectralToolbox.Spectral1D as S1D
  File "/jenkins/workspace/TransportMaps-testpypi-mpi/COMPILER/gcc/MACHINE/reynolds/PYTHON_EXE/python2/VENV_SYS/virtualenv/venv_TransportMaps-testpypi-mpi_python2/lib/python2.7/site-packages/SpectralToolbox/Spectral1D/__init__.py", line 37, in <module>
    import SpectralToolbox.Spectral1D.OrthogonalPolynomials
  File "/jenkins/workspace/TransportMaps-testpypi-mpi/COMPILER/gcc/MACHINE/reynolds/PYTHON_EXE/python2/VENV_SYS/virtualenv/venv_TransportMaps-testpypi-mpi_python2/lib/python2.7/site-packages/SpectralToolbox/Spectral1D/OrthogonalPolynomials.py", line 39, in <module>
    import orthpol_light
ImportError: libgfortran.so.3: cannot open shared object file: No such file or directory
Build step 'Execute shell' marked build as failure
Sending e-mails to: tmteam-dev@mit.edu
[WS-CLEANUP] Deleting project workspace...
[WS-CLEANUP] Skipped based on build state FAILURE
Finished: FAILURE