Console Output

Started by upstream project "TransportMaps-testpypi-mpi" build number 110
originally caused by:
 [URLTrigger] A change within the response URL invocation (log)
Running as SYSTEM
[EnvInject] - Loading node environment variables.
Building remotely on reynolds in workspace /jenkins/workspace/TransportMaps-testpypi-mpi/COMPILER/gcc/MACHINE/reynolds/PYTHON_EXE/python3/VENV_SYS/virtualenv
[WS-CLEANUP] Deleting project workspace...
[WS-CLEANUP] Deferred wipeout is used...
[GitCheckoutListener] SCM 'hudson.scm.NullSCM' is not of type GitSCM
[virtualenv] $ /bin/bash /tmp/jenkins4108928169346279857.sh
created virtual environment CPython3.8.10.final.0-64 in 114ms
  creator CPython3Posix(dest=/jenkins/workspace/TransportMaps-testpypi-mpi/COMPILER/gcc/MACHINE/reynolds/PYTHON_EXE/python3/VENV_SYS/virtualenv/venv_TransportMaps-testpypi-mpi_python3, clear=False, global=False)
  seeder FromAppData(download=False, pip=latest, setuptools=latest, wheel=latest, pkg_resources=latest, via=copy, app_data_dir=/home/jenkins/.local/share/virtualenv/seed-app-data/v1.0.1.debian.1)
  activators BashActivator,CShellActivator,FishActivator,PowerShellActivator,PythonActivator,XonshActivator

TEST_NAME: TransportMaps-testpypi-mpi
HOSTNAME: reynolds
PATH: /jenkins/workspace/TransportMaps-testpypi-mpi/COMPILER/gcc/MACHINE/reynolds/PYTHON_EXE/python3/VENV_SYS/virtualenv/venv_TransportMaps-testpypi-mpi_python3/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin:/home/jenkins/bin
VENV_OPTS: 
PATH: /jenkins/workspace/TransportMaps-testpypi-mpi/COMPILER/gcc/MACHINE/reynolds/PYTHON_EXE/python3/VENV_SYS/virtualenv/venv_TransportMaps-testpypi-mpi_python3/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin:/home/jenkins/bin
PY-VERS: Python 3.8.10
PY-CMD: import logging;import TransportMaps as TM;import warnings;warnings.simplefilter('ignore');TM.tests.run_all(logging.ERROR,ttype='parallel')

Upgrading pip
Collecting pip
  Using cached pip-21.3.1-py3-none-any.whl (1.7 MB)
Installing collected packages: pip
  Attempting uninstall: pip
    Found existing installation: pip 20.0.2
    Uninstalling pip-20.0.2:
      Successfully uninstalled pip-20.0.2
Successfully installed pip-21.3.1
Installing numpy
Collecting numpy
  Using cached numpy-1.22.3-cp38-cp38-manylinux_2_17_x86_64.manylinux2014_x86_64.whl (16.8 MB)
Installing collected packages: numpy
Successfully installed numpy-1.22.3
Checking out requirements files
Installing requirements
Requirement already satisfied: numpy>=1.14 in /jenkins/workspace/TransportMaps-testpypi-mpi/COMPILER/gcc/MACHINE/reynolds/PYTHON_EXE/python3/VENV_SYS/virtualenv/venv_TransportMaps-testpypi-mpi_python3/lib/python3.8/site-packages (from -r requirements.txt (line 1)) (1.22.3)
Collecting orthpol_light>=1.0.1
  Using cached orthpol_light-1.0.1-cp38-cp38-linux_x86_64.whl
Collecting scipy
  Using cached scipy-1.8.0-cp38-cp38-manylinux_2_17_x86_64.manylinux2014_x86_64.whl (41.6 MB)
Collecting SpectralToolbox>=1.0.7
  Using cached SpectralToolbox-1.0.12-cp38-cp38-linux_x86_64.whl
Collecting dill
  Using cached dill-0.3.4-py2.py3-none-any.whl (86 kB)
Collecting scikit-sparse
  Using cached scikit_sparse-0.4.6-cp38-cp38-linux_x86_64.whl
Installing collected packages: scipy, orthpol-light, SpectralToolbox, scikit-sparse, dill
Successfully installed SpectralToolbox-1.0.12 dill-0.3.4 orthpol-light-1.0.1 scikit-sparse-0.4.6 scipy-1.8.0
Collecting mpi4py
  Using cached mpi4py-3.1.3-cp38-cp38-linux_x86_64.whl
Collecting h5py
  Using cached h5py-3.6.0-cp38-cp38-manylinux_2_12_x86_64.manylinux2010_x86_64.whl (4.5 MB)
Requirement already satisfied: numpy>=1.14.5 in /jenkins/workspace/TransportMaps-testpypi-mpi/COMPILER/gcc/MACHINE/reynolds/PYTHON_EXE/python3/VENV_SYS/virtualenv/venv_TransportMaps-testpypi-mpi_python3/lib/python3.8/site-packages (from h5py->-r requirements-H5PY.txt (line 2)) (1.22.3)
Installing collected packages: mpi4py, h5py
Successfully installed h5py-3.6.0 mpi4py-3.1.3
Requirement already satisfied: mpi4py in /jenkins/workspace/TransportMaps-testpypi-mpi/COMPILER/gcc/MACHINE/reynolds/PYTHON_EXE/python3/VENV_SYS/virtualenv/venv_TransportMaps-testpypi-mpi_python3/lib/python3.8/site-packages (from -r requirements-MPI.txt (line 1)) (3.1.3)
Collecting mpi_map>=2.0
  Using cached mpi_map-2.6-py3-none-any.whl (37 kB)
Requirement already satisfied: dill in /jenkins/workspace/TransportMaps-testpypi-mpi/COMPILER/gcc/MACHINE/reynolds/PYTHON_EXE/python3/VENV_SYS/virtualenv/venv_TransportMaps-testpypi-mpi_python3/lib/python3.8/site-packages (from mpi_map>=2.0->-r requirements-MPI.txt (line 2)) (0.3.4)
Installing collected packages: mpi-map
Successfully installed mpi-map-2.6
Installing TransportMaps
Looking in indexes: https://testpypi.python.org/pypi
ERROR: Could not find a version that satisfies the requirement TransportMaps (from versions: none)
ERROR: No matching distribution found for TransportMaps
Build step 'Execute shell' marked build as failure
Sending e-mails to: tmteam-dev@mit.edu
[WS-CLEANUP] Deleting project workspace...
[WS-CLEANUP] Skipped based on build state FAILURE
Finished: FAILURE